Home Download Buy Blog Forum Support

How do I prevent .tcl from defaulting to HTML(Tcl) mode?

How do I prevent .tcl from defaulting to HTML(Tcl) mode?

Postby jeremy_c on Tue Nov 29, 2011 3:18 pm

When I create or open a new .tcl file, sublime 2 defaults to HTML (Tcl) mode. Tcl mode should be the default, I am unsure why .tcl is even mapped to HTML (Tcl) mode. Anyway, how can I change this?

Thanks,

Jeremy
jeremy_c
 
Posts: 3
Joined: Tue Nov 29, 2011 3:17 pm

Re: How do I prevent .tcl from defaulting to HTML(Tcl) mode?

Postby skaet on Wed Nov 30, 2011 3:36 am

The most desirable way is simply adding this to your "Global Settings - User" file:

Code: Select all
{
   "ignored_packages":
   [
      "TCL/HTML (Tcl)"
   ]
}


The HTML (Tcl) language file is therefore skipped unless you explicitly select it.
skaet
 
Posts: 93
Joined: Thu Sep 16, 2010 3:37 pm

Re: How do I prevent .tcl from defaulting to HTML(Tcl) mode?

Postby rmweiss on Thu Jan 19, 2012 8:33 am

Hi,

I have the same problem, and i tried to solve it with the following entry in Global.sublime-settings:

Code: Select all
"ignored_packages": ["Vintage", "TCL/HTML (Tcl)"]


but it didn't work (.tcl files still defaults to "HTML (Tcl)").

Is this the wrong syntax, or have i to do something different?

(ST2 Build is 2139 because of a different problem with newer versions)

Thanks,
René
rmweiss
 
Posts: 1
Joined: Wed Jan 18, 2012 5:37 pm


Return to General Discussion

Who is online

Users browsing this forum: henkbb, Yahoo [Bot] and 4 guests