Home Download Buy Blog Forum Support

Performance issues

Performance issues

Postby kbsingh on Wed Nov 30, 2011 5:37 pm

Hi Guys,

I'm running sublime2 build 2139, with the built in plugins + Git plugin. the repository I am editing only has a few files ( < 40 ). This is on linux/x86_64/2.6.32 CentOS-6. I have the twilight clour theme selected. Minimap is turned off. Side bar is enabled, and I have a project setup.

The first day or so, everything was very snappy and things went through really quickly, I could move around and do operations and nothing would seem slow. Over the last 2 days however, things seem to have become very lethargic. Doing a pagedown takes a almost a second+ to complete, a find will take a few seconds to return ( document has less than 500 lines of text ).

I've disabled the Git plugin and it makes no difference. If it helps and if there is something obviously out of expectations with support libraries, here is what ldd reports on my machine:

linux-vdso.so.1 => (0x00007fff4e7ff000)
libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x0000003bcb000000)
libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x0000003bcc000000)
libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00000031f8a00000)
libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x00000031f4a00000)
libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x0000003bcbc00000)
libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x0000003bcac00000)
libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00000031f9200000)
libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x0000003bcb800000)
libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00000031f5a00000)
libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00000031f8600000)
libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x0000003bca400000)
libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x0000003bca800000)
libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00000031f3200000)
libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00000031f3a00000)
libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00000031f4600000)
librt.so.1 => /lib64/librt.so.1 (0x00000031f2200000)
libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00000031f2600000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00000031f1600000)
libdl.so.2 => /lib64/libdl.so.2 (0x00000031f1200000)
libutil.so.1 => /lib64/libutil.so.1 (0x00000031fde00000)
libm.so.6 => /lib64/libm.so.6 (0x00000031f1a00000)
libX11.so.6 => /usr/lib64/libX11.so.6 (0x00000031f4200000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00000031fca00000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00000031fb600000)
libc.so.6 => /lib64/libc.so.6 (0x00000031f0e00000)
libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00000031f6a00000)
libXext.so.6 => /usr/lib64/libXext.so.6 (0x00000031f4e00000)
libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00000031f6600000)
libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00000031f7200000)
libXi.so.6 => /usr/lib64/libXi.so.6 (0x00000031f5e00000)
libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00000031f7600000)
libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00000031f6e00000)
libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00000031f7e00000)
libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00000031faa00000)
libresolv.so.2 => /lib64/libresolv.so.2 (0x00000031f2e00000)
libselinux.so.1 => /lib64/libselinux.so.1 (0x00000031f2a00000)
libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00000031fa600000)
libz.so.1 => /lib64/libz.so.1 (0x00000031f1e00000)
libexpat.so.1 => /lib64/libexpat.so.1 (0x00000031f5200000)
/lib64/ld-linux-x86-64.so.2 (0x00000031f0a00000)
libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00000031f3e00000)
libXau.so.6 => /usr/lib64/libXau.so.6 (0x00000031f3600000)

What should I / could I be looking for ?
--
Karanbir Singh { http://www.karan.org/ }
Recovering Vim (ab)user looking for a better all around coding environment
kbsingh
 
Posts: 3
Joined: Wed Nov 30, 2011 5:25 pm

Re: Performance issues

Postby jps on Wed Nov 30, 2011 9:16 pm

Do you have any other plugins installed? Does http://www.sublimetext.com/docs/2/revert.html fix it?
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: Performance issues

Postby kbsingh on Thu Dec 01, 2011 2:49 am

Hi,
jps wrote:Do you have any other plugins installed? Does http://www.sublimetext.com/docs/2/revert.html fix it?


Resetting seems to have made some difference ( placebo ? ). Opening a couple of projects, getting the Git plugin installed and things seem to come back to where they were. I can very willingly live without the Git plugin for now, but it would be great to have included in the setup at some point. I'm just completely out of time to be able to look at code, offer patches. But is there any other info I can provide that might help diagnose and maybe help fix the issue ?

I'm running a pretty clean x86_64 machine ( ie. almost no 32bit code ), Git -1.7.1, perl-5.10.1

thanks and regards,

- KB
kbsingh
 
Posts: 3
Joined: Wed Nov 30, 2011 5:25 pm


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 20 guests