Home Download Buy Blog Forum Support

LaTeXTools: compilation issue

LaTeXTools: compilation issue

Postby trinix on Wed Nov 30, 2011 9:04 pm

Hey,

When using LaTeXTools for ST2, certain errors do not produce a feedback message when compiling the file. I came across such a behavior when I just copied some text from word to a tex file on ST2. This copied text included apostrophes, which caused the problem - no feedback when compiling. If I use TextMate, I get the following message, which helps me solve the problem.

Code: Select all
Package inputenc Error: Keyboard character used is undefined


Any ideas how to optimize that behavior with LATeXTools for ST2?

The tex file is available here: http://dl.dropbox.com/u/41850/testprposal2.tex

Best
Christian
OS X, MacTeX 2013, ST 2, Skim
trinix
 
Posts: 30
Joined: Tue Sep 20, 2011 1:57 pm

Re: LaTeXTools: compilation issue

Postby Marciano on Thu Dec 01, 2011 4:30 am

Yep, my bad. The short story is that I have to robustify the make_pdf command in LaTeXTools (which is invoked when you do a build).

The longer story is that (1) tex complains that it cannot encode a character (the apostrophe, as you correctly state), and copies the offending character in the log file; then, (2) Python throws a Unicode error when it encounters that character when parsing the log file.

I think in this case the right thing to do is to parse the log file telling Python to ignore characters it can't encode. However, more generally, I must also make sure that the build command never fails silently. I'll try to fix this ASAP.

As a stopgap measure, sometimes you can get some insight into what went wrong by looking at the console (Ctrl+`); LaTeXTools spits out a lot of debugging info there, and of course any Python error messages appear there, too.

Thanks!
Marciano
 
Posts: 146
Joined: Fri Sep 18, 2009 2:55 am

Re: LaTeXTools: compilation issue

Postby Marciano on Thu Dec 01, 2011 5:49 am

OK, I think I have robustified the relevant code. It works for me on your file... Please let me know! Thanks---M
Marciano
 
Posts: 146
Joined: Fri Sep 18, 2009 2:55 am

Re: LaTeXTools: compilation issue

Postby trinix on Fri Dec 02, 2011 2:26 pm

Excellent, Marciano!.

Now it outputs the error and jumps to the right point inside the code - great.


Best
Christian
OS X, MacTeX 2013, ST 2, Skim
trinix
 
Posts: 30
Joined: Tue Sep 20, 2011 1:57 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 15 guests