Home Download Buy Blog Forum Support

Keybindings Regression Bug Dev Build 2152

Keybindings Regression Bug Dev Build 2152

Postby kuroir on Sun Dec 25, 2011 9:10 am

I've been using Beta for some time now. I downloaded the latest available Dev Build ( 2152 ) and noticed that my indent / unindent keybindings broke.

I'm using a Mac and Spanish ISO Keyboard.

Code: Select all
  { "keys": ["super+]"], "command": "indent" },
  { "keys": ["super+["], "command": "unindent" },


These config works on Beta. On my keyboard I need to press the following keys:

Code: Select all
super+alt++  ( super+] )
super+alt+`  ( super+[ )

and they work.

On DEV the default keys stopped working. If I change the keybinding to super+alt++ then it works, BUT the second one doesn't work at all ( super+alt+` )

I'm assuming this is a regression bug, since installing beta works without trouble.
kuroir
 
Posts: 71
Joined: Thu Sep 01, 2011 11:28 pm
Location: Mexico

Re: Keybindings Regression Bug Dev Build 2152

Postby jps on Mon Dec 26, 2011 3:11 am

FWIW none of the input handling code has changed in the current series of dev builds - if you temporarily go back to 2139, does the key binding start working for you again?
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Keybindings Regression Bug Dev Build 2152

Postby kuroir on Mon Dec 26, 2011 9:25 am

Yes, it works on 2139 :)
kuroir
 
Posts: 71
Joined: Thu Sep 01, 2011 11:28 pm
Location: Mexico

Re: Keybindings Regression Bug Dev Build 2152

Postby jps on Mon Dec 26, 2011 2:10 pm

Just to confirm, did you reinstall 2139 to verify?
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Keybindings Regression Bug Dev Build 2152

Postby kuroir on Tue Dec 27, 2011 8:44 am

Like I mentioned in the first post:

I'm assuming this is a regression bug, since installing beta works without trouble.

( yes, I installed the beta and it works again. )
kuroir
 
Posts: 71
Joined: Thu Sep 01, 2011 11:28 pm
Location: Mexico

Re: Keybindings Regression Bug Dev Build 2152

Postby kuroir on Wed Dec 28, 2011 3:43 am

Bump?

Bump!
kuroir
 
Posts: 71
Joined: Thu Sep 01, 2011 11:28 pm
Location: Mexico


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Yahoo [Bot] and 17 guests