Home Download Buy Blog Forum Support

Error with Dev Build 2158

Error with Dev Build 2158

Postby candysunplus on Fri Jan 06, 2012 2:00 am

OS:ArchLinux X64

update from Dev Build 2157 to 2158

Error is: end pattern with unmatched parenthesis in regex ^(?!(?=\S)

and all hightlight in my sublime faild

change syntax type will report error like

Javascript:
Error loading syntax file "Packages/JavaScript/JavaScript.tmLanguage": Error in regex: end pattern at escape in regex ([a-zA-Z_?.$][\w?.$]*)\.(prototype)\.([a-zA-Z_?.$][\w?.$]*)\s*(=)\s*(function)?\s*(\()(.*?)(\

CSS:
Error loading syntax file "Packages/CSS/CSS.tmLanguage": Error in regex: end pattern with unmatched parenthesis in regex \s*(?=[:.*#a-zA-Z]

Python:
Error loading syntax file "Packages/Python/Python.tmLanguage": Error in regex: end pattern with unmatched parenthesis in regex \b(?i:(0x\h*)L

......
candysunplus
 
Posts: 1
Joined: Fri Jan 06, 2012 1:55 am

Re: Error with Dev Build 2158

Postby tiger2wander on Fri Jan 06, 2012 4:52 am

Same here, I use Arch Linux X64 and I've just updated to 2158 and Error dialog show every time I start sublime or open new file.
Look like there are some problem with regex engine or regex definition.

Please advise!
--
Best regard!
Uoc Nguyen
tiger2wander
 
Posts: 8
Joined: Mon Apr 18, 2011 10:27 am

Re: Error with Dev Build 2158

Postby zombat on Fri Jan 06, 2012 11:19 am

Unfortunately this is still not fixed in 2159.
zombat
 
Posts: 6
Joined: Mon Sep 12, 2011 1:36 pm

Re: Error with Dev Build 2158

Postby tiger2wander on Sat Jan 07, 2012 7:37 am

On 2160 now and not fixed :o
--
Best regard!
Uoc Nguyen
tiger2wander
 
Posts: 8
Joined: Mon Apr 18, 2011 10:27 am


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 15 guests