Home Download Buy Blog Forum Support

auto_complete_* Settings are not working

auto_complete_* Settings are not working

Postby corsen2000 on Fri Jan 13, 2012 12:29 pm

1)
auto_complete_commit_on_tab defaults to false, but this setting appears to be ignored.
In my application if I start typing something, auto complete will pop up. Hitting the tab key will fill in the auto complete even when setting "auto_complete_commit_on_tab" is set to false. I tried setting this to false in my user config as well, but I had the same problem.
2)
auto_complete_with_fields does not seem to be working.
In ruby when I type in "ea" auto completion will appear. Hitting the tab key will cause "each" to be filled out which is from auto completion. This is not expected. I have a snippet defined with tab shortcut "ea". I don't think this should happen because "auto_complete_with_fields" is set to false. Based on the comment I think that the auto completion "each" should be hidden because "ea" is a exact match to the "ea" snippet. Even if auto complete and snippets were equal I find it kinda odd that it would select "each" instead of "ea" when only "ea is typed in. "ea" is an exact match to the snippet.

Sublime Text 2 version 2165.
Linux 32 bit (I am running Ubuntu 10.10)

Thank you,
Bryan

--Update--
My windows machine seems to ignore these settings as well. Tab still commits the completion even when auto_complete_commit_on_tab is set to false. Windows does behave better though in the "ea" scenario by selecting the snippet "ea" instead of the completion "each". Not sure why this would be different.
corsen2000
 
Posts: 8
Joined: Fri Jan 13, 2012 12:16 pm

Re: auto_complete_* Settings are not working

Postby corsen2000 on Fri Jan 13, 2012 2:43 pm

Number 2 from the above post may be a non issue. I just realized that the completion menu will pre-select whatever your last chosen completion was, when that menu was up. By manually moving it to "ea" snippet and hitting tab, this is now the default selection when completion comes up. I think this is pretty cool if that is how it is supposed to work. I may just not understand what "auto_complete_with_fields" means. Can anyone explain that?

I am still seeing issue 1 on all machines though where auto_complete_commit_on_tab defaults is set false but tab does commit auto completion.

Anyone else having trouble with this setting on their machines?

Thank you.
corsen2000
 
Posts: 8
Joined: Fri Jan 13, 2012 12:16 pm

Re: auto_complete_* Settings are not working

Postby sibweber on Sat Feb 11, 2012 8:47 am

I'm on a Mac (Lion) and I am also experiencing issue #1 (commit_on_tab).

In addition to that, in HTML, whenever I commit (with either key), I end up with two opening brackets, i.e. <<html... Is anyone else experiencing this?

Thanks,
Sibylle
sibweber
 
Posts: 1
Joined: Sat Feb 11, 2012 8:43 am

Re: auto_complete_* Settings are not working

Postby jps on Sat Feb 11, 2012 10:31 am

If the auto complete popup is visible, tab will accept the current completion irrespective of the auto_complete_commit_on_tab setting. The setting controls if enter accepts the completion or not.
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm


Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 23 guests