Home Download Buy Blog Forum Support

Syntax Specific User Settings for "Plain Text"

Syntax Specific User Settings for "Plain Text"

Postby submich on Wed Jan 18, 2012 4:15 pm

I set word_wrap globally off via 'Base File.sublime-settings' and want to enable it via syntax specific settings file. This works fine for JavaScript (via 'JavaScript.sublime-settings'), but doesn't work for Plain Text files (via 'Plain text.sublime-settings'; also tried 'Plain Text.sublime-settings' - doesn't work either).
Both config files are in the Packages/User directory (and found when opened via Preferences -> File Settings (More) -> Syntax Specific (User)).

Any ideas what could be causing this?

Thanks!
submich
 
Posts: 5
Joined: Fri Jan 13, 2012 4:44 pm

Re: Syntax Specific User Settings for "Plain Text"

Postby nick. on Fri Jan 20, 2012 12:56 am

I tried and it seems to be working for me (build 2165).
In my /User/Base File.sublime-settings:
Code: Select all
{
   "word_wrap": false
}


and in /User/Plain text.sublime-settings:
Code: Select all
{
   "word_wrap": true
}


Did you use the Preferences > File Settings -- More > Syntax Specific -- User menu to create the Plain text.sublime-settings file?
nick.
 
Posts: 266
Joined: Wed Jan 18, 2012 3:45 am

Re: Syntax Specific User Settings for "Plain Text"

Postby submich on Mon Jan 23, 2012 12:52 pm

nick. wrote:Did you use the Preferences > File Settings -- More > Syntax Specific -- User menu to create the Plain text.sublime-settings file?


That did the trick. My original file was manually created (copied from the JavaScript Settings file). I deleted this file and used the suggested menu entry to recreate it. Now it works.

Strange: The (manually created) old file had exactly the same filename and same content as the new one. It was also found and opened by the suggested menu entry. Even when opening it via that entry, the settings had no effect.

Anyway: It works now. Thank you very much.
submich
 
Posts: 5
Joined: Fri Jan 13, 2012 4:44 pm


Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 19 guests