Home Download Buy Blog Forum Support

The libgio problem again....

The libgio problem again....

Postby brownegg on Fri Feb 03, 2012 3:15 pm

I'm on Crunchbang Linux (based on Debian Squeeze).

$ ldd ./sublime_text
linux-vdso.so.1 => (0x00007fffaf5bb000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00007f5d7b914000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00007f5d7b667000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00007f5d7b445000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x00007f5d7b193000)

So I know I have *a* version of libgio installed... otherwise I suppose sublime wouldn't work at all.

However, because my version is < 2.26, I have the "multiple instance" problem when editing files from the command line.

I've searched everywhere for a way to update my libgio, but can't find that it exists in any package in Debian. Someone out there must be using ST2 with a Debian system... can you tell me how or point me to a resource telling me how to update this lib?

Thanks in advance.
brownegg
 
Posts: 3
Joined: Fri Feb 03, 2012 2:58 pm

Re: The libgio problem again....

Postby ajpalkovic on Fri Feb 03, 2012 5:17 pm

ajpalkovic
 
Posts: 142
Joined: Fri Jun 10, 2011 10:21 pm

Re: The libgio problem again....

Postby brownegg on Fri Feb 03, 2012 6:28 pm

From that page:

$ git clone git://git.gnome.org/glib
$ cd glib
$ git co 2.26.1

>> git: 'co' is not a git command ...

$ ./autogen.sh --prefix=/opt/lib/glib2.26

>> is it glib2.26 or glib that should be used? earlier it looks like glib...

$ make
$ sudo make install

>> Also, everything in /glib says 2.0. Thanks for the help, but that's not the clearest answer. :)
brownegg
 
Posts: 3
Joined: Fri Feb 03, 2012 2:58 pm

Re: The libgio problem again....

Postby ajpalkovic on Fri Feb 03, 2012 10:21 pm

git co is an alias he has for git checkout

glib2.26 is just a directory name. You can call it foobar if you want, it doesn't really matter.

The last step was to tell the os to look in the new directory for any libs before it starts sublime.
ajpalkovic
 
Posts: 142
Joined: Fri Jun 10, 2011 10:21 pm

Re: The libgio problem again....

Postby brownegg on Fri Feb 03, 2012 11:39 pm

Still compiling glib, but your tips helped get me this far. Thanks!
brownegg
 
Posts: 3
Joined: Fri Feb 03, 2012 2:58 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Yahoo [Bot] and 10 guests

cron