Home Download Buy Blog Forum Support

HTML5 & jQuery Packages

HTML5 & jQuery Packages

Postby MrMartineau on Mon Aug 15, 2011 10:12 pm

I'm not sure if this is the right place to post this but I have been converting two brilliant Textmate bundles for use with Sublime: Karl Swedberg's jQuery bundle & John Muhl's HTML5 bundle. They do take quite a while & there is no converter per se so I have not finished the conversion yet, but you can still use what is already there.

Download & contribute
HTML5 package - https://github.com/mrmartineau/HTML5
jQuery package - https://github.com/mrmartineau/jQuery

I would actually love some help with the conversions so if anyone's interested, please fork the projects & get stuck in! Also, if anyone has any suggestions or critiques, please let me know.

Cheers guys

Zander
Last edited by MrMartineau on Tue Aug 23, 2011 12:12 am, edited 1 time in total.
@MrMartineau || Setup Sublime Text quickly: Find out all you need at https://github.com/mrmartineau/SublimeTextSetup
MrMartineau
 
Posts: 78
Joined: Thu Jul 28, 2011 8:35 am

Re: HTML5 & jQuery Packages

Postby salazr on Thu Aug 18, 2011 6:10 pm

Hey man, I tried adding these guys with the Package Manager (via Add Repo) and ran into a bunch of parse errors.

Probably my fault, but couldn't find any documentation on the install process from the github pages.

Would love to get this up and running.. any tips?


Sample console output:


error: Error parsing snippet: Error parsing plist xml: Failed to open file In file "Packages/HTML5-Sublime-Text-Package/mrmartineau-HTML5-Sublime-Text-Package-d2c610c/Snippets/<details>.tmSnippet" In file Packages/HTML5-Sublime-Text-Package/mrmartineau-HTML5-Sublime-Text-Package-d2c610c/Snippets/<details>.tmSnippet
salazr
 
Posts: 2
Joined: Thu Aug 18, 2011 4:00 pm

Re: HTML5 & jQuery Packages

Postby MrMartineau on Tue Aug 23, 2011 12:12 am

The HTML5 package conversion is complete & it has been added to the 'Package Control' repo list.

I have also created a Placeholders package for lorem ipsum text & dummy HTML content. Check it out here: https://github.com/mrmartineau/Placeholders
@MrMartineau || Setup Sublime Text quickly: Find out all you need at https://github.com/mrmartineau/SublimeTextSetup
MrMartineau
 
Posts: 78
Joined: Thu Jul 28, 2011 8:35 am

Re: HTML5 & jQuery Packages

Postby wbond on Wed Aug 24, 2011 6:15 pm

If you experience an error like the following when opening Sublime Text:

Code: Select all
Unable to run package setup:

Traceback (most recent call last):
  File "./PackageSetup.py", line 155, in upgrade
    upgradePackage(pkg, pristinedir, datadir, backupdir)
  File "./PackageSetup.py", line 148, in upgradePackage
    os.path.join(backupdir, base), inhibitOverwrite)
  File "./PackageSetup.py", line 64, in upgradeArchive
    fname = os.path.join(pkgdir, f)
  File ".\posixpath.py", line 70, in join
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 49: ordinal not in range(128)


Go to your Packages directory, then go up a level and into the Installed Packages directory. Delete HTML5.sublime-package.

The new version of Package Control (v1.1.4) should prevent the Installed Packages directory from getting in this state such that PackageSetup.py (part of Sublime Text) fails in this way.
wbond
 
Posts: 531
Joined: Mon Feb 28, 2011 5:33 am

Re: HTML5 & jQuery Packages

Postby MrMartineau on Sun Aug 28, 2011 9:24 am

I also updated the HTML5 package because of the issues Windows users were having, apologies for that
@MrMartineau || Setup Sublime Text quickly: Find out all you need at https://github.com/mrmartineau/SublimeTextSetup
MrMartineau
 
Posts: 78
Joined: Thu Jul 28, 2011 8:35 am

Re: HTML5 & jQuery Packages

Postby ilovecode on Sat Sep 03, 2011 5:24 am

After installing ST2 I immediately installed the HTML5 and jQuery packages via the Plugin-Installer. After a while I got really annoyed by the following behavior:

Code: Select all
div[TAB]


completes to

Code: Select all
<div id="" class=""></div>


which is fine. But when I tab to select the id-Attribute and delete it, then hit tab once again it triggers another completion of the div tag.
ilovecode
 
Posts: 9
Joined: Sat Sep 03, 2011 5:19 am

Re: HTML5 & jQuery Packages

Postby MrMartineau on Sat Sep 03, 2011 8:18 am

I have come across this as well & raised the point in another thread - basically Sublime needs to NOT allow triggers from within another trigger.
@MrMartineau || Setup Sublime Text quickly: Find out all you need at https://github.com/mrmartineau/SublimeTextSetup
MrMartineau
 
Posts: 78
Joined: Thu Jul 28, 2011 8:35 am

Re: HTML5 & jQuery Packages

Postby whololo on Fri Jan 13, 2012 8:58 am

The jQuery bundle is now out of date.

Please merge with kswedberges new updates.

Thanks
whololo
 
Posts: 12
Joined: Fri Jul 08, 2011 10:47 am

Re: HTML5 & jQuery Packages

Postby syndrael on Wed Feb 29, 2012 10:47 am

Hello,
I've installed jQuery package - https://github.com/mrmartineau/jQuery
But could you tell me how to use it ?
Best regards
S.
syndrael
 
Posts: 6
Joined: Tue Dec 27, 2011 9:27 am

Re: HTML5 & jQuery Packages

Postby 200 on Wed Feb 29, 2012 7:29 pm

By first adding to the package manager the url
Code: Select all
https://github.com/mrmartineau/jQuery
, and then selecting it from the list for installing, everything seems fine until this box:
Attachments
errbox.gif
errbox.gif (10.14 KiB) Viewed 20921 times
200
 
Posts: 18
Joined: Wed Feb 22, 2012 6:40 pm

Next

Return to Plugin Announcements

Who is online

Users browsing this forum: Exabot [Bot] and 6 guests