Home Download Buy Blog Forum Support

Cut/Copy/Paste linux64 bit - serious problems

Cut/Copy/Paste linux64 bit - serious problems

Postby pigmej on Thu Mar 22, 2012 10:56 am

Hey,

I experienced a *huge* bug in copy/paste on linux 64 bit. (I saw some similar windows7 problems there, but windows != linux, and I found out something more/different than there - but it's for sure releated)
I can't sometimes copy / paste anything to ST2 windows (doesn't matter new, existing, etc).
Sometimes it works OK but for example I have to wait some seconds to get the confirmation in satus bar "Cut XX characters".
It doesn't works neither with keybord shortcuts and with the menu (also I tried to boud it something different, but still no result) shift + ins also doesn't work then.

What's worse, when It happens it sometimes causes a HUGE problem, because I found out that after that the cursor mark ( | ) and the current line mark are in different places, seems not a big problem ? Until you will try to edit/delete something in the buffer. Then for me happens one from those things:
- ST2 crashes completely
- The data in the buffer is 'destroyed' and I have to close it and reopen.

I tested the 'fresh' sublime install without any plugins and the same happens there.

What's strange, on 32bit linux it seems working cool. I checked also different window managers / desktop managers on linux (gnome3/kde4.8/xfce/lxde) and the problem is on all of them.

Ps. Great work with ST2 ;)
pigmej
 
Posts: 5
Joined: Thu Mar 22, 2012 10:45 am

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby pigmej on Thu Mar 22, 2012 11:15 am

Above the fresh 2190 full startup log from Console.

Code: Select all
startup, version: 2190 linux x64 channel: dev
executable: /home/pigmej/Apps/Sublime Text 2/sublime_text
working dir: /home/pigmej
packages path: /home/pigmej/.config/sublime-text-2/Packages
settings path: /home/pigmej/.config/sublime-text-2/Settings
source packages: 48 installed packages: 0, running PackageSetup
error parsing session: No data at: 0:0
error parsing session: No data at: 0:0
Py_GetProgramName(): sublime_text
Py_GetExecPrefix(): .
Py_GetProgramFullPath():
Py_GetPath(): :./lib/python26.zip:./lib/python2.6/:./lib/python2.6/plat-linux2:./lib/python2.6/lib-tk:./lib/python2.6/lib-old:./lib/python2.6/lib-dynload
Py_GetPythonHome(): .
PackageSetup returned: -1
catalogue loaded
found 4 files for base name Default.sublime-keymap
found 1 files for base name Default.sublime-mousemap
found 1 files for base name Main.sublime-menu
Generating syntax summary
Generating meta info summary
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/comment.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/copy_path.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/delete_word.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/detect_indentation.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/duplicate_line.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/echo.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/exec.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/fold.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/font.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/goto_line.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/indentation.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/kill_ring.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/mark.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/new_templates.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/open_file_settings.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/paragraph.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/save_on_focus_lost.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/scroll.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/set_unsaved_view_name.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/side_bar.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/sort.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/swap_line.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/switch_file.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/transform.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/transpose.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Default/trim_trailing_white_space.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/Diff/diff.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/HTML/encode_html_entities.py
Reloading plugin /home/pigmej/.config/sublime-text-2/Packages/HTML/html_completions.py
plugin init time: 0.065931
loading bindings
loading pointer bindings
found 1 files for base name Default.sublime-theme
theme loaded
app ready
pre session restore time: 0.640798
using gamma: 1 (err: 0)
wrote startup cache, added files: 88 orphaned files: 0 total files: 88 cache hits: 0
startup time: 0.825759 (package setup was run)
loaded 934 snippets


I also found out that it sometimes prints in linux console ( ./sublime_text )
Code: Select all
(sublime_text:22701): GLib-CRITICAL **: g_main_loop_quit: assertion `loop != NULL' failed


Can I help in any other way ?
pigmej
 
Posts: 5
Joined: Thu Mar 22, 2012 10:45 am

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby pigmej on Tue Mar 27, 2012 11:22 am

I think the problem may be because the affected system is for example Fedora17 (new libraries etc), tested same configuration but other distro and worked fine (at least during tests).

I also noticed that the biggest problems (ST2 crash, mixed the contents of buffer etc) are experienced when there are more than one ST2 running (the windows), or the file is oppened in two windows.
pigmej
 
Posts: 5
Joined: Thu Mar 22, 2012 10:45 am

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby chrisdamato on Fri Apr 13, 2012 9:04 am

I am having the same problem ... it appeared just before I was getting out my credit card to purchase a license. I am a Windows refugee and I have come to count on ST2 but I don't have the chops to diagnose this problem further on my own.
chrisdamato
 
Posts: 1
Joined: Fri Apr 13, 2012 9:02 am

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby jean on Thu May 03, 2012 4:15 am

Same problem too :( I tried to run 32-bit version in 64-bit kernel, but the problem did not disappear. Together with expiration of builds, in which there was no problem (<2181), does ST2 not usable for me. I can't work without copy/paste. The only thing left for me to do - is to run ST2 in Wine.
jean
 
Posts: 6
Joined: Thu May 03, 2012 4:01 am

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby jean on Thu May 03, 2012 5:25 am

I'm using gentoo, versions of installed packages - http://pastebin.com/fmSCP1Fd

The first time I encountered this problem in 2181, but then I did not deal with it and just rolled back to the previous build.
Yesterday, the previous build is informed that it expired. I downloaded the 2181 problem appeared again. I tried in 2195 - it kept the problem.

Steps to reproduce:

1) Start ST2
2) Type 2 lines in new file and select first line
3) Edit|Cut (or Crtl+X) - text is not cut, but copied to clipboard
4) After that, the cursor stops moving when clicking on keyboard arrows. However, highlighting the current line is moving.Undo working incorrect.
5) Сursor can be moved with the mouse, but even after the move does not respond to keystrokes.
6) Usually closing - opening of tab helps, but sometimes ST2 crashes.
jean
 
Posts: 6
Joined: Thu May 03, 2012 4:01 am

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby jps on Thu May 03, 2012 6:45 am

Does the same thing still happen after reverting to a clean state: http://www.sublimetext.com/docs/2/revert.html?
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby jean on Thu May 03, 2012 8:26 am

jps wrote:Does the same thing still happen after reverting to a clean state: http://www.sublimetext.com/docs/2/revert.html?

Yes, I did it, but it did not help.
jean
 
Posts: 6
Joined: Thu May 03, 2012 4:01 am

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby jean on Fri May 04, 2012 10:07 am

I've made one more observation. If you wait 15-20 seconds, then everything becomes normal after the status bar appears "Cut X characters"
jean
 
Posts: 6
Joined: Thu May 03, 2012 4:01 am

Re: Cut/Copy/Paste linux64 bit - serious problems

Postby jean on Thu May 10, 2012 10:09 am

Any ideas / workarounds?
jean
 
Posts: 6
Joined: Thu May 03, 2012 4:01 am

Next

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 28 guests