Home Download Buy Blog Forum Support

Tab size reverts to 4

Tab size reverts to 4

Postby barryglenn on Fri Feb 17, 2012 8:45 pm

I'm on v2 2165. I added "tab_size" : 2 to the User File Settings. It works more of the time than not but frequently reverts to 4 spaces for a tab in ways I can't reproduce. I altered the default settings as well to know affect. If I exit and restart it will honor the setting but at some point reverts back. Is anyone else having this problem and does anyone know how to fix it please?
barryglenn
 
Posts: 1
Joined: Fri Feb 17, 2012 8:42 pm

Re: Tab size reverts to 4

Postby jps on Sat Feb 18, 2012 6:15 am

jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Tab size reverts to 4

Postby abathologist on Sat Mar 24, 2012 10:19 pm

I'm having the same issue despite having already set "detect_indentation": false. Strangely, it only seems to be happening with .yml docs. Is it possible that the syntax definition is overruling the user-prefs? If so, how do I override this?
abathologist
 
Posts: 18
Joined: Thu Mar 15, 2012 1:29 am

Re: Tab size reverts to 4

Postby C0D312 on Sat Mar 24, 2012 10:38 pm

abathologist wrote:I'm having the same issue despite having already set "detect_indentation": false. Strangely, it only seems to be happening with .yml docs. Is it possible that the syntax definition is overruling the user-prefs? If so, how do I override this?


User Preferences supersede syntax-specific which supersedes default

Make sure it's in User/Preferences.sublime-settings
C0D312
 
Posts: 1063
Joined: Sun Jul 10, 2011 3:23 am

Re: Tab size reverts to 4

Postby abathologist on Sat Mar 24, 2012 11:10 pm

User Preferences supersede syntax-specific which supersedes default

Make sure it's in User/Preferences.sublime-settings


Thanks for the help! But my preferences are indeed in the user folder. In any case, according to the docshttp://www.sublimetext.com/docs/2/settings.html,

Settings files are consulted in this order:

Packages/Default/Preferences.sublime-settings
Packages/Default/Preferences (<platform>).sublime-settings
Packages/User/Preferences.sublime-settings
<Project Settings>
Packages/<syntax>/<syntax>.sublime-settings
Packages/User/<syntax>.sublime-settings
<Buffer Specific Settings>


But I've checked the Packages/<syntax> directory and there's nothing there.

....

After further testing. I believe the problem *was* initially about the auto-detect, but I foolishly forgot to restart the program *or even to close and reopen the files I was working on.* That's embarrassing, but I guess I'll just know better for next time.

Thanks for your help!
abathologist
 
Posts: 18
Joined: Thu Mar 15, 2012 1:29 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 23 guests