Home Download Buy Blog Forum Support

Copy text (CMD+C) not working consistently

Copy text (CMD+C) not working consistently

Postby zonak on Thu Apr 12, 2012 5:18 pm

This issue has been bugging me from day one.

I am on OS X 10.7.3 and using ST 2 2190.

Loving everything about ST so far but this thing is driving me nuts:

Doing CMD + C on the keyboard should obviously copy the selected text. Very often it simply does not work. I noticed that when it does work the status bar shows a message like:

Copied nnn characters.

and it started being the obvious indicator when issuing a Copy command from the keyboard fails. I even tried holding the buttons longer, checking my keyboard settings but nothing helped.

Just as a clarification, this happens ONLY in ST - don't have the issue anywhere else.

Is someone else running into this issue? Is there something I can do, check? Can someone please look into this?

I hate not using ST because of something like this.


Thanks,
<z/>
zonak
 
Posts: 2
Joined: Thu Apr 12, 2012 5:09 pm

Re: Copy text (CMD+C) not working consistently

Postby adzenith on Thu Apr 12, 2012 5:23 pm

I have never had this problem (also on 10.7.3). What plugins do you have installed? Have you tried reverting? http://www.sublimetext.com/docs/2/revert.html
adzenith
 
Posts: 1214
Joined: Mon Oct 19, 2009 9:12 pm

Re: Copy text (CMD+C) not working consistently

Postby zonak on Mon Apr 16, 2012 3:39 pm

At least I know I am not alone:

viewtopic.php?f=3&t=6253
viewtopic.php?f=3&t=5914

I know it is a different OS but there is definitely something going on.

Thank you for the recommendation to do the revert - I'll try that too and post the results. The tough part is that it happens intermittently and testing in those cases is not that straightforward.

<z/>
zonak
 
Posts: 2
Joined: Thu Apr 12, 2012 5:09 pm

Re: Copy text (CMD+C) not working consistently

Postby Ildefonse on Thu Jun 21, 2012 10:16 am

Is there any news on this? It is also affecting me, on max OS X 10.6.8, and only occurs in ST, build 2200.
Ildefonse
 
Posts: 15
Joined: Tue Jun 19, 2012 8:48 am

Re: Copy text (CMD+C) not working consistently

Postby simplypixie on Tue Nov 20, 2012 1:52 pm

I have also been struggling with this issue and the only way around it that I have just found is to re-declare the key binding in my User Key Bindings file - seems to work fine now. Hope this helps others.
simplypixie
 
Posts: 1
Joined: Tue Nov 20, 2012 1:51 pm

Re: Copy text (CMD+C) not working consistently

Postby pier on Wed Nov 21, 2012 12:56 am

Never had this issue in Lion or Mountain Lion either...

The other day I had this weird issue with Adobe Flash Pro, and it turned out the problem was another software called "Hiss" which translates growl messages into Mountain Lion native notifications. My point being that maybe the problem is somewhere else...
pier
 
Posts: 92
Joined: Fri Jun 15, 2012 2:47 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 25 guests