Home Download Buy Blog Forum Support

Markdown syntax highlight

Markdown syntax highlight

Postby dsarch on Sun Oct 23, 2011 11:06 pm

Hello,

Seems markdown syntax highlight is not working. I have been trying to open some github README.md files and they are recognized as markdown files, but they do not get any syntax colouring.

Can it be fixed ?

Thanks !
dsarch
 
Posts: 62
Joined: Tue May 03, 2011 2:31 am

Re: Markdown syntax highlight

Postby tito on Sun Oct 23, 2011 11:36 pm

Some "Color schemes" ( preferences -> Color schemes ) don't include markdown highlight. Change it.
Give APIs, let the community build the rest!
https://github.com/titoBouzout
tito
 
Posts: 706
Joined: Thu Sep 29, 2011 2:27 pm
Location: Montevideo, Uruguay

Re: Markdown syntax highlight

Postby dsarch on Mon Oct 24, 2011 12:14 am

Hello,

Which one worked for you ?
dsarch
 
Posts: 62
Joined: Tue May 03, 2011 2:31 am

Re: Markdown syntax highlight

Postby tito on Mon Oct 24, 2011 2:48 am

Monokai works, I prefer Twigligth but I'm currently switching crazy from colour scheme to color scheme.
Give APIs, let the community build the rest!
https://github.com/titoBouzout
tito
 
Posts: 706
Joined: Thu Sep 29, 2011 2:27 pm
Location: Montevideo, Uruguay

Re: Markdown syntax highlight

Postby dsarch on Mon Oct 24, 2011 4:51 am

Thanks,

Im using the idleFingers theme, works well.
dsarch
 
Posts: 62
Joined: Tue May 03, 2011 2:31 am

Re: Markdown syntax highlight

Postby robdodson on Fri Apr 27, 2012 2:56 pm

I still can't get markdown syntax highlighting to work. Using Monokai or any other theme. Tried it on .markdown and .md files. I also tried installing the Markdown Build package using the Package Manager but that didn't help at all.

Sublime Text 2 Beta, Build 2181
robdodson
 
Posts: 9
Joined: Thu Apr 26, 2012 6:15 pm

Re: Markdown syntax highlight

Postby pom421 on Sat Mar 01, 2014 2:47 pm

I have the same issue (for Sublime 2.0.2, on Mac OS X), and i fix it :
- use a good Color scheme (Cobalt for example)
- verify in Preferences > Package settings > Markdown preview > Settings - Default, that "enable_highlight" is set to true
pom421
 
Posts: 1
Joined: Sat Mar 01, 2014 2:43 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 20 guests

cron