Home Download Buy Blog Forum Support

Bug: Manual/API Folding

Bug: Manual/API Folding

Postby facelessuser on Fri Jun 01, 2012 5:52 pm

There are a couple of folding bugs that exist in the latest ST2.

1. You used to be able to click on the fold icon in the text, and the folded region would expand; now you can only click the fold arrow in the gutter. Now this may not be a problem if it wasn't for the next issue.

2. When folding multi-line regions with the api or using the fold shortcut [ctrl+shift+[], the region gets folded, and a gutter arrow appears (usually on the wrong line, the one before), and the arrow is not functional.

I am assuming the issue arises from the bad calculation of the gutter icon (single line manual folds have the icon calculated just fine, and seem to work just fine). I assume the gutter icon unfolds the regions of the line it is on. So, since the multi-line folded regions place the gutter icon one line before the actual start of the fold region, it is non-functional. If a fold gutter icon just happens to exist on the line from another already folded region or from the automatic function gutter fold icons, then this issue will not be noticeable, so you must fold a multi-line region on lines that do not already have a fold icon to see the issue.

Personally, I liked the missing feature described in possible bug 1 and would like it to return, but bug 2 is a problem that does need fixing.
facelessuser
 
Posts: 1545
Joined: Tue Apr 05, 2011 7:38 pm

Re: Bug: Manual/API Folding

Postby quarnster on Fri Jun 01, 2012 5:56 pm

I ran into this also and posted a minimal plugin showing the issue
quarnster
 
Posts: 389
Joined: Tue Nov 29, 2011 11:34 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 12 guests