Home Download Buy Blog Forum Support

Couple interface glitches in recent v2 builds

Couple interface glitches in recent v2 builds

Postby Rhywun on Fri Jun 24, 2011 3:50 am

This is build 2069 on OS X 10.6.7 - I believe the same glitches occur on my work machine which is XP.

First glitch - the minimap appears to the left of where it should when I create a new file:

Image

Second glitch - the horizontal scrollbar is missing when I open a file (with word wrap off), until I scroll down and then it appears:

Image

PS. Really liking this editor - especially the multiple selections... very elegant! Fits in great on both Mac and Windows too.
Rhywun
 
Posts: 39
Joined: Fri Jun 24, 2011 3:19 am
Location: Brooklyn

Re: Couple interface glitches in recent v2 builds

Postby jag on Sun Jun 03, 2012 5:02 am

I also seemed to be having similar glitches, where interface elements were simply not showing up.

So I'm demoing Sublime 2 (build 2181) to see if I want to ditch Espresso for lack of a dual-view feature, but I've had this really crazy issue where the interface seems to be missing it's graphics. It has happened consistently after opening Sublime a handful of times. I even tried trashing my installed version of the app, and then redownloading - same issue. Then I even tried downloading a dev build (was on build 2181, but tried build 2195) but still same issue is seems.

Finally, I downloaded the Soda Theme and the issue was apparently resolved by installing that theme. So perhaps it was an issue with the current default theme??

sublime-interface-bug.png
sublime-interface-bug.png (248.32 KiB) Viewed 867 times
jag
 
Posts: 4
Joined: Sun Jun 03, 2012 4:52 am

Re: Couple interface glitches in recent v2 builds

Postby jps on Mon Jun 04, 2012 12:36 am

It appears some required files are missing - http://www.sublimetext.com/docs/2/revert.html will fix it
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Couple interface glitches in recent v2 builds

Postby Caffeinix on Thu Jul 26, 2012 8:35 pm

I, too, am having these problems, on both Mac and Linux. Moving aside the Sublime Text 2 folder under ~/Library/Application Support did not fix the issue for me. This affects more than the tabs, as well — the column guide disappears except if you scroll to the very bottom of the document, and the blinking insertion point marker starts out invisible whenever it moves (which makes text navigation very difficult, since you have to wait for the insertion point marker to fade back in if you want to know where your insertion point is).
Caffeinix
 
Posts: 4
Joined: Thu Jul 26, 2012 8:28 pm

Re: Couple interface glitches in recent v2 builds

Postby Caffeinix on Wed Jan 23, 2013 4:20 am

jps wrote:It appears some required files are missing - http://www.sublimetext.com/docs/2/revert.html will fix it


This appears to be the same bug as http://www.sublimetext.com/forum/viewtopic.php?f=2&t=5908&p=42171#p42171, which looks like it's due to region drawing.
Caffeinix
 
Posts: 4
Joined: Thu Jul 26, 2012 8:28 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 20 guests