Home Download Buy Blog Forum Support

SBT2 Installation problem on Mac OS X 10.7.4

SBT2 Installation problem on Mac OS X 10.7.4

Postby mysticviews on Thu Jun 14, 2012 6:50 am

I am trying to install SBT2 on the following setting

Code: Select all
Mac OS X 10.7
tbc:~ mystic$ which python
/Library/Frameworks/Python.framework/Versions/2.7/bin/python
tbc:~ mystic$ python -V
Python 2.7.2



I downloaded the dmg package from SBT2 website and install it but I get an error after I opened the SBT2 application

Code: Select all
Unable to run package setup:

Failed to load module

Traceback (most recent call last):
  File "./PackageSetup.py", line 7, in <module>
    import zipfile
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 4, in <module>
    import struct, os, time, sys, shutil
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/struct.py", line 1, in <module>
    from _struct import *
ImportError: No module named _struct


As I have Python2.7 as default I dont know why SBT2 is going after Python2.6

Can anyone help me I really want to use SBT2 as my work editor tool.
mysticviews
 
Posts: 4
Joined: Thu Jun 14, 2012 6:44 am

Re: SBT2 Installation problem on Mac OS X 10.7.4

Postby kobzar on Thu Jun 14, 2012 8:10 am

ls -la /Library/Frameworks/Python.framework/Versions

most be

drwxr-xr-x 4 root wheel 136 Apr 10 06:55 .
drwxr-xr-x 6 root wheel 204 Apr 10 06:50 ..
drwxrwxr-x 10 root admin 340 Apr 10 06:55 2.7
lrwxr-xr-x 1 root wheel 3 May 17 10:27 Current -> 2.7

if not, try
cd /Library/Frameworks/Python.framework/Versions
sudo rm Current
sudo ln -s /Library/Frameworks/Python.framework/Versions/2.7 Current
kobzar
 
Posts: 18
Joined: Mon Apr 23, 2012 5:53 am

Re: SBT2 Installation problem on Mac OS X 10.7.4

Postby mysticviews on Thu Jun 14, 2012 2:20 pm

@Kobzar, I have tried what you said but still the same error. Its eating my brain.

tbc:~ mystic$ ls -la /Library/Frameworks/Python.framework/Versions
total 8
drwxr-xr-x 5 root admin 170 Jun 12 2011 .
drwxr-xr-x 6 root admin 204 Jun 12 2011 ..
drwxrwxr-x 11 root admin 374 Jun 12 2011 2.7
drwxrwxr-x 10 root admin 340 Jun 9 2011 3.0
lrwxr-xr-x 1 root admin 3 Sep 25 2011 Current -> 2.7
tbc:~ mystic$ cd /Library/Frameworks/Python.framework/Versions
tbc:Versions mystic$ sudo rm Current
Password:
tbc:Versions mystic$ sudo ln -s /Library/Frameworks/Python.framework/Versions/2.7 Current
mysticviews
 
Posts: 4
Joined: Thu Jun 14, 2012 6:44 am

Re: SBT2 Installation problem on Mac OS X 10.7.4

Postby jps on Fri Jun 15, 2012 9:32 pm

Sublime Text always uses Python 2.6, please check it hasn't been removed from your system.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: SBT2 Installation problem on Mac OS X 10.7.4

Postby mysticviews on Sun Jun 17, 2012 3:04 pm

@jps- Are you sure in Mac OSX Python 2.6 is needed? I have Windows desktop where SBT2 is working fine without Python 2.6.
mysticviews
 
Posts: 4
Joined: Thu Jun 14, 2012 6:44 am

Re: SBT2 Installation problem on Mac OS X 10.7.4

Postby jps on Sun Jun 17, 2012 3:22 pm

Yes, on Windows Sublime Text includes its own version of Python. Sublime Text uses the system version of Python 2.6 on OS X, as it's a standard part of the OS.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: SBT2 Installation problem on Mac OS X 10.7.4

Postby mysticviews on Mon Nov 19, 2012 4:09 pm

I installed the fresh copy of Python 2.6
But, still I am having the same issue as mentioned in the question

I can import the
Code: Select all
_struct module
but its complaining in STB2 application launch.


Code: Select all
tbc:mystic $ python
Python 2.6 (trunk:66714:66715M, Oct  1 2008, 18:36:04)
[GCC 4.0.1 (Apple Computer, Inc. build 5370)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> from _struct import *
>>>
mysticviews
 
Posts: 4
Joined: Thu Jun 14, 2012 6:44 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 21 guests