Home Download Buy Blog Forum Support

Bug: setting "tab_completion" is being ignored (build 2200)

Bug: setting "tab_completion" is being ignored (build 2200)

Postby Ildefonse on Tue Jun 19, 2012 8:53 am

Configuration:

Code: Select all
{
   "auto_complete_commit_on_tab": false,
   "tab_completion": false
}


Console result after pressing TAB while typing a word:

Code: Select all
command: insert_best_completion {"default": "   ", "exact": true}


I assume this is due to the keys configuration in the global key bindings file:

Code: Select all
{ "keys": ["tab"], "command": "insert_best_completion", "args": {"default": "\t", "exact": true} },
   { "keys": ["tab"], "command": "insert_best_completion", "args": {"default": "\t", "exact": false},
      "context":
      [
         { "key": "setting.tab_completion", "operator": "equal", "operand": true }
      ]
   },


Only when I actually remove these lines from the keys configuration file, does TAB not cause a completion.
Hence, it appears the setting "tab_completion": false does not work as it should.

It appears to have worked 6 months ago for this person: http://sublimetext.userecho.com/topic/8 ... -reindent/
but seems to be broken now?
Ildefonse
 
Posts: 15
Joined: Tue Jun 19, 2012 8:48 am

Re: Bug: setting "tab_completion" is being ignored

Postby jps on Tue Jun 19, 2012 9:13 am

The setting is working as indented, that's the command that should be triggered when tab_completion is set to false. Even when tab_completion is false, it is still designed to trigger snippets, which is what insert_best_completion will do when the exact parameter is true.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Bug: setting "tab_completion" is being ignored (build 2200)

Postby Ildefonse on Tue Jun 19, 2012 9:48 am

What do you mean by "when the exact parameter is true"? It doesn't complete snippets, it simply auto completes words.
For example, if this text would be in a file, and i would type:

para<TAB>, it would auto complete it to "parameter"
This is not a snippet, just a word.

That cannot be the intended behavior when the setting is set to "false".
Ildefonse
 
Posts: 15
Joined: Tue Jun 19, 2012 8:48 am

Re: Bug: setting "tab_completion" is being ignored (build 2200)

Postby jps on Tue Jun 19, 2012 11:46 am

If the auto complete window is showing, pressing tab will always select the current entry: you'll need to press escape first to hide the window.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Bug: setting "tab_completion" is being ignored (build 2200)

Postby Ildefonse on Tue Jun 19, 2012 1:41 pm

Yes I am aware of that fact. This is however, very counter productive, since the auto complete window shows up for just about every single word I type.
And besides, if this is the case, what is the purpose of the setting "tab_completion", if it is completely ignored?

And before you say it, yes I have tried setting the auto completion window delay from 50ms to 500ms.
This introduces another bug however, where the auto complete screen pops up randomly in inappropriate places when typing fast (for example behind a => or . symbol, yielding very strange results and the introduction of the word "php" when pressing tab). I made a screencast of this behaviour:

http://screencast.com/t/NwViOnfl

Look how often "php" is inserted. The auto complete system is really buggy.
I would really love to purchase Sublime and use it on all our machines in the office for each employee, but I am really reluctant unless these issues get fixed. I can't be the only one who is affected by them.
Ildefonse
 
Posts: 15
Joined: Tue Jun 19, 2012 8:48 am

Re: Bug: setting "tab_completion" is being ignored (build 2200)

Postby Ildefonse on Tue Jun 19, 2012 1:48 pm

Let me also put it in another way. If you say it is the proper behavior for TAB to complete the autocomplete, when the setting "tab_completion" is set to false, then tell me please how I can reconfigure Sublime so that it only accepts auto completions with ENTER only. Since both TAB and ENTER do the same now, it is a bit redundant.

From the Sublime documentation I think the setting is clearly meant to disable auto complete on tab:

http://www.sublimetext.com/docs/2/tab_completion.html

Disabling Tab Completion

Sometimes tab completion isn't desirable. To turn it off, add this line to Preferences/File Settings - User:

"tab_completion": false
Ildefonse
 
Posts: 15
Joined: Tue Jun 19, 2012 8:48 am

Re: Bug: setting "tab_completion" is being ignored (build 2200)

Postby Ildefonse on Thu Jun 21, 2012 10:17 am

JPS, can you reply to my last 2 comments?
Ildefonse
 
Posts: 15
Joined: Tue Jun 19, 2012 8:48 am

Re: Bug: setting "tab_completion" is being ignored (build 2200)

Postby Ildefonse on Mon Jun 25, 2012 2:45 am

Still awaiting a conclusive answer on this.
Ildefonse
 
Posts: 15
Joined: Tue Jun 19, 2012 8:48 am

Re: Bug: setting "tab_completion" is being ignored (build 2200)

Postby jps on Mon Jun 25, 2012 2:47 am

This is working by design
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Bug: setting "tab_completion" is being ignored (build 2200)

Postby Ildefonse on Mon Sep 03, 2012 10:38 pm

jps wrote:This is working by design


Seriously, how can you state that after reading all of the above?
There are like 3 different auto complete settings, and none of them work. Nice design.
Ildefonse
 
Posts: 15
Joined: Tue Jun 19, 2012 8:48 am

Next

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 10 guests