Home Download Buy Blog Forum Support

ISSUE: Completions List. No words from buffer?

Re: ISSUE: Completions List. No words from buffer?

Postby dsarch on Fri Jun 29, 2012 4:12 am

Hello @squ1b3r,

Thank you so much for bringing it to the forum, I will send an email to Jon (@jps), hoping he can help us.

I really love Djaneiro and it is an invaluable tool for Django developers.

Does anyone have a tip on how can we fix this ?

Thanks a lot !
dsarch
 
Posts: 62
Joined: Tue May 03, 2011 2:31 am

Re: ISSUE: Completions List. No words from buffer?

Postby dsarch on Fri Jun 29, 2012 2:31 pm

Up.
dsarch
 
Posts: 62
Joined: Tue May 03, 2011 2:31 am

Re: ISSUE: Completions List. No words from buffer?

Postby jbrooksuk on Fri Jun 29, 2012 9:28 pm

Can you try JavaScript syntax for me?

Seems to be working on that, but nothing else; at least PHP.
jbrooksuk
 
Posts: 772
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: ISSUE: Completions List. No words from buffer?

Postby squ1b3r on Sat Jun 30, 2012 1:46 pm

Ok. I've got this. For some reason ST2 starts doing thing when you have trigger name like this "verbose_name = " and that was a problem.

Djaneiro is fixed now.
squ1b3r
 
Posts: 45
Joined: Fri Feb 11, 2011 6:35 am

Re: ISSUE: Completions List. No words from buffer?

Postby pier on Sun Nov 11, 2012 8:01 am

I'm having the exact same issue.

How did you finally solve it?

In my completions file, there are no = ...

What is exactly causing this problem?
pier
 
Posts: 92
Joined: Fri Jun 15, 2012 2:47 am

Re: ISSUE: Completions List. No words from buffer?

Postby pier on Mon Nov 12, 2012 6:38 am

BUMP

This is getting even more weird...

Triggers with "verbose" characters work and still get auto complete from word in buffer, but ONLY if the sublime-completions list is short.

When the sublime-completions is long (and I don't know how long), then the issue at hand happens. Triggers work but autocomplete from buffer is completely disabled.

Is this a bug?
A normal behaviour?
Can someone shed some light to this issue?

HEEEELP!!!!
pier
 
Posts: 92
Joined: Fri Jun 15, 2012 2:47 am

Re: ISSUE: Completions List. No words from buffer?

Postby oferei on Tue Mar 12, 2013 9:18 am

Having the same problem. A sublime-completions list causes the buffer words to be totally ignored. But it isn't size related. The following completion single-handedly reproduces the bug:

Code: Select all
{ "trigger": "curSpeed(X", "contents": "abc" }


I have the word "curSpeed" in the buffer, but it is ignored. The problem is with the parenthesis. Remove it and the problem goes away. Actually, the only valid characters are: letters, numbers, hyphen (-) and underscore (_)
oferei
 
Posts: 2
Joined: Tue Mar 12, 2013 8:11 am

Previous

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 14 guests