Home Download Buy Blog Forum Support

Vintage mode: / & ? should repeat searches

Vintage mode: / & ? should repeat searches

Postby rufwork on Mon Jul 16, 2012 1:17 am

Yoda might say I've got much to unlearn... but I think it's worth getting ST2 to follow VIm on this one.

When I search in VIm, I can repeat the search for the same text by hitting "/" followed by enter or "?" followed by enter. In Vintage mode, a search for nothing is executed instead. And, like the trained ape I am, I keep hitting /<enter> over and over, waiting for the search to kick in.

So my expectation for an empty search in Vintage mode would be the same as hitting F3 or shift-F3 in Sublime Text without Vintage mode enabled.

Please heavens, this is driving me crazy. ;^) Surprised it wasn't elsewhere on the forum. Otherwise, wow, great editor.
rufwork
 
Posts: 5
Joined: Wed Jul 11, 2012 2:44 pm

Re: Vintage mode: / & ? should repeat searches

Postby quarnster on Mon Jul 16, 2012 5:33 am

I suggest opening up an issue on the Vintage plugin's github page
quarnster
 
Posts: 389
Joined: Tue Nov 29, 2011 11:34 am

Re: Vintage mode: / & ? should repeat searches

Postby rufwork on Mon Jul 16, 2012 1:42 pm

That looks perfect (direct link to issues and new issue, which I'll update if I missed its already being in there). Thanks. Sorry I missed that.
rufwork
 
Posts: 5
Joined: Wed Jul 11, 2012 2:44 pm


Return to Ideas and Feature Requests

Who is online

Users browsing this forum: No registered users and 11 guests