Home Download Buy Blog Forum Support

Install Package issue - UnicodeDecodeError

Install Package issue - UnicodeDecodeError

Postby darksoulsong on Wed Aug 01, 2012 7:31 pm

I just downloaded Sublime Test 2 (vs 2.0.1 build 2217), and I´m giving it a try.

I have installed "Package Control" and get the following message when I inserted the command "Install package" in the command pallete:

Code: Select all
Exception in thread Thread-2:
Traceback (most recent call last):
  File ".\threading.py", line 532, in __bootstrap_inner
  File ".\Package Control.py", line 1890, in run
  File ".\Package Control.py", line 1759, in make_package_list
  File ".\Package Control.py", line 1121, in list_available_packages
  File ".\Package Control.py", line 1066, in list_repositories
  File ".\Package Control.py", line 175, in get_repositories
  File ".\Package Control.py", line 148, in fetch_channel
  File ".\Package Control.py", line 1007, in download_url
  File ".\Package Control.py", line 622, in download
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe3 in position 90: ordinal not in range(128)


I googled it, but had no luck. I´ve seen people with a similar issue (the UnicodeDecodeError). A coworker got the very same problem.
Right now I´m trying the portable version, but again, no luck.

Any help would be VERY appreciated, since it looks very promising... don´t want to stop using it because of something like this.

Thanks.
darksoulsong
 
Posts: 1
Joined: Wed Aug 01, 2012 7:20 pm

Re: Install Package issue - UnicodeDecodeError

Postby arthurse on Tue Sep 18, 2012 12:41 pm

i'm having the same problem.
do you found a resolution?
thanks.
arthurse
 
Posts: 2
Joined: Tue Sep 18, 2012 12:40 pm

Re: Install Package issue - UnicodeDecodeError

Postby arthurse on Tue Sep 18, 2012 1:05 pm

solved the problem here, i'm behind a proxy server at my work, in package control settings i put my proxy address at line

"http_proxy": "",

there is this solution too https://github.com/wbond/sublime_packag ... issues/119
arthurse
 
Posts: 2
Joined: Tue Sep 18, 2012 12:40 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Yahoo [Bot] and 17 guests