Home Download Buy Blog Forum Support

Problems with cut shortcut... may be bug

Problems with cut shortcut... may be bug

Postby Jet4Fire on Fri Jun 29, 2012 9:05 pm

when i push "ctrl+x" i lost cursor on editor, using latest xubuntu x64 and sublime text 2 linux x64, what the problem?
Jet4Fire
 
Posts: 4
Joined: Fri Jun 29, 2012 9:01 pm

Re: Problems with cut shortcut... may be bug

Postby tito on Fri Jun 29, 2012 9:40 pm

view -> show console

There paste and enter this:

Code: Select all
sublime.log_commands(True)

Then, just focus the view, select something and press CTRL+X

The output after the selection should be:

Code: Select all
command: cut

Maybe you have some package interfering with this action.
Give APIs, let the community build the rest!
https://github.com/titoBouzout
tito
 
Posts: 851
Joined: Thu Sep 29, 2011 2:27 pm
Location: Montevideo, Uruguay

Re: Problems with cut shortcut... may be bug

Postby Jet4Fire on Fri Jun 29, 2012 10:18 pm

writing
Code: Select all
command: cut
, and after lost cursor, side panel and open files
Jet4Fire
 
Posts: 4
Joined: Fri Jun 29, 2012 9:01 pm

Re: Problems with cut shortcut... may be bug

Postby Jet4Fire on Sat Jun 30, 2012 4:11 am

Video of this problem: https://vimeo.com/44958741
Jet4Fire
 
Posts: 4
Joined: Fri Jun 29, 2012 9:01 pm

Re: Problems with cut shortcut... may be bug

Postby jps on Sat Jun 30, 2012 5:26 am

Thanks for the video, can you follow these instructions (backing up your data directory first), and let me know if it still occurs? http://www.sublimetext.com/docs/2/revert.html
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Problems with cut shortcut... may be bug

Postby zackelan on Tue Jul 24, 2012 12:32 am

I'm encountering the same issue. Deleting my ~/.config/sublime-text-2 directory does not resolve the issue.

More details:
- I'm running 64-bit Ubuntu 11.04 and XFCE 4.8.0 (the OP was running Xubuntu, which makes me wonder if this is XFCE-related. I can try to reproduce the behavior in Gnome or Fluxbox if that would help narrow it down)
- I have the latest Sublime 2.0.1 (installed using the instructions here: http://www.ubuntuupdates.org/ppa/sublime)

Reliable repro steps on my box:
- rm -r ~/.config/sublime-text-2
- subl foo.txt
- type abc<enter>def<enter>
- select "abc" on line 1, ctrl-x
// the abc line doesn't disappear at this point, as I'd expect it to
- place cursor on line 3, ctrl-v
// line 3 now contains "abc", line 1 still has "abc"
- press enter a few times
// new lines are created as expected, but the cursor doesn't move - it remains at the beginning of line 3

Let me know if there's any more info I can provide. I love Sublime and use it on Windows, but my primary development is done in Ubuntu and this funky behavior essentially blocks me from using it every day.
zackelan
 
Posts: 1
Joined: Tue Jul 24, 2012 12:16 am

Re: Problems with cut shortcut... may be bug

Postby Jet4Fire on Wed Aug 08, 2012 9:34 am

More and more i hear about this issue from peoples who use XFCE.
Well, problem not solved, developers are silent, i go back to vim!
Jet4Fire
 
Posts: 4
Joined: Fri Jun 29, 2012 9:01 pm

Re: Problems with cut shortcut... may be bug

Postby stefanlindmark on Tue Oct 09, 2012 9:49 am

I'm using Sublime on Ubuntu and I'm seeing the same problem. No Sublime expert by any means but I hope I can submit enough information here for the problem to be fixed.

One observation that feels like it could be relevant and important:
The problem is the same if Edit-menu -> Copy is used. This eliminates the problem source of the OS/virtualization messing up keyboard input / modifier keys.

The problem is also the same regardless of amount of text selected or if no text is selected at all.
Edit: Removing .config/sublime-text-2 and reverting to factory default settings doesn't make any difference.

Sublime 2.0.1, Build 2217, 32-bit, Licensed
Client OS: Ubuntu 12.04 32-bit
Host OS: Windows 7 running VirtualBox

Steps to reproduce cursor problem and restore functionality:
  • Place the cursor anywhere in a text file
  • Press Ctrl-C or Edit-menu -> Copy
  • Press arrow keys. The text cursor will not move. The shadow to the left marking current line number will move however.
  • Select a window in the host OS (Win7 in my case)
  • Select the tab in Sublime/Ubuntu again
  • Press arrow keys. The text cursor is now moving again.
  • Sometimes the host OS window select needs to be repeated.

This is the output of the Sublime console:
command: move {"by": "characters", "forward": false} (cursor still moving here)
command: move {"by": "characters", "extend": true, "forward": true} (cursor still moving here)
command: move {"by": "characters", "extend": true, "forward": true} (cursor still moving here)
command: copy
command: move {"by": "lines", "forward": false} (cursor frozen here at the position before copy)
command: move {"by": "lines", "forward": false} (cursor frozen here)
command: move {"by": "lines", "forward": true} (cursor frozen here)
command: move {"by": "lines", "forward": true} (cursor frozen here)
(switching to host window and back again here)
command: move {"by": "lines", "forward": false} (cursor moving again here)
command: move {"by": "lines", "forward": false} (cursor moving again here)
stefanlindmark
 
Posts: 3
Joined: Tue Oct 09, 2012 8:53 am

Re: Problems with cut shortcut... may be bug

Postby stefanlindmark on Tue Oct 09, 2012 11:33 am

Another observation:
Switching to Unity 2D at the Ubuntu login screen seems to make the cursor work again.
After switching back again to Unity 3D Sublime still has the cursor working, at least temporarily. Will report back after some extended use if it stays in this state or turns stationary on copy again.
stefanlindmark
 
Posts: 3
Joined: Tue Oct 09, 2012 8:53 am

Re: Problems with cut shortcut... may be bug

Postby jordanmswanson on Wed Nov 07, 2012 7:54 pm

I am having this exact problem on Ubuntu 12.10 with XFCE, it really makes the program hard to use, and Unity 3d is unusable for performance reasons for me.

I would like to see this bug resolved.
jordanmswanson
 
Posts: 1
Joined: Wed Nov 07, 2012 7:51 pm

Next

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 22 guests