Home Download Buy Blog Forum Support

Sublime Text 2 silently exits on startup (Debian Linux)

Sublime Text 2 silently exits on startup (Debian Linux)

Postby dschooh on Thu Aug 30, 2012 9:57 am

Hello there,

after successfully using Sublime Text 2.0.1 64 bit on Debian Linux Unstable for quite a while now, it suddenly stopped working. When starting it from the command line, it directly and quietly exits with an error code of 0. I already stashed ~/.config/sublime-text-2 and reinstalled with no luck.

It might be that Sublime stopped working after I did a system dist-upgrade, but since I do them on a daily basis, I couldn't really tell.

Any help, also on how to get some debug output, is appreciated.

Many thanks!
dschooh
 
Posts: 2
Joined: Thu Aug 30, 2012 9:49 am

Re: Sublime Text 2 silently exits on startup (Debian Linux)

Postby whitequark on Thu Aug 30, 2012 11:49 am

Try
Code: Select all
strace -eopen -ff sublime_text
, that might hint you if it tries to open some file right before quitting and finds it to be unaccessible.
whitequark
 
Posts: 6
Joined: Wed Aug 29, 2012 6:03 pm

Re: Sublime Text 2 silently exits on startup (Debian Linux)

Postby dschooh on Thu Aug 30, 2012 3:39 pm

Thanks for your reply. The output is at https://gist.github.com/3531039. I have another machine with the same setup to which I will compare the output tomorrow. Despite some locale-files that are not found, does anything look suspicious there?
dschooh
 
Posts: 2
Joined: Thu Aug 30, 2012 9:49 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Yahoo [Bot] and 20 guests