Home Download Buy Blog Forum Support

Mediawiki bundle

Mediawiki bundle

Postby themicksa on Thu Aug 23, 2012 10:56 am

Hi,
I'd be grateful for some advice on how (or if it's possible) to properly install the Textmate bundle for Mediawiki (https://github.com/textmate/mediawiki.tmbundle) on ST2. I've tried loading it both manually and through the add repository function but cannot get it to work and tinkered with things to no result. Currently I'm getting the following: "Error loading syntax file "Packages/Mediawiki.tmbundle/Syntaxes/Mediawiki.tmLanguage": Unexpected capture value"
Wikitext is about the limit of my coding knowledge, although I'm managing to write plenty of snippets in ST2 for the wiki project I'm working on. But if I could just get the syntax colouring of the mediawiki bundle to work as well I'd be a very happy bunny.
Any ideas would be much appreciated.
themicksa
 
Posts: 3
Joined: Thu Aug 23, 2012 9:49 am

Re: Mediawiki bundle

Postby tolmark12 on Sun Sep 02, 2012 9:48 pm

I'm getting the same error, any thoughts sublime community?
tolmark12
 
Posts: 5
Joined: Tue Aug 28, 2012 12:48 am

Re: Mediawiki bundle

Postby depsir on Tue Sep 04, 2012 9:58 am

In the last commit some changes caused the error..

A quick fix could be to run in the mediawiki.tmbundle folder the command
Code: Select all
git checkout 3ccef83114fb2dfd610aa9139c8f657400c176c0

unfortunately I don't have time to correct the error but maybe someone else could..
depsir
 
Posts: 2
Joined: Tue Sep 04, 2012 9:15 am

Re: Mediawiki bundle

Postby tolmark12 on Tue Sep 04, 2012 10:14 pm

Worked great, thanks! Do you know what the problem is, maybe I could fix it if I can find some time.
tolmark12
 
Posts: 5
Joined: Tue Aug 28, 2012 12:48 am

Re: Mediawiki bundle

Postby depsir on Sun Sep 16, 2012 1:23 pm

I think that the bug has been fixed in the tbates repository (https://github.com/tbates/mediawiki.tmbundle)
depsir
 
Posts: 2
Joined: Tue Sep 04, 2012 9:15 am

Re: Mediawiki bundle

Postby themicksa on Mon Oct 01, 2012 10:47 am

Belated thanks to you both for kicking this along; I expected to get an email alert if anyone responded, but maybe I need to enable that somewhere in the forum settings.

In any case I downloaded and reinstalled the mediawiki tmbundle from tbates as suggested but I still see no syntax highlighting. Also I am getting the same error on startup:
That gave me this Error loading syntax file "Packages/mediawiki.tmbundle/Syntaxes/Mediawiki.tmLanguage": Unexpected capture value

I tried fixing the code in that file, as suggested elsewhere, from &lt; and &gt; to proper < > signs but that seemed to make things worse.
Error loading syntax file "Packages/mediawiki.tmbundle/Syntaxes/Mediawiki.tmLanguage": Error parsing plist xml: Error reading end tag. In file "Packages/mediawiki.tmbundle/Syntaxes/Mediawiki.tmLanguage"

Could the syntax formatting or encloding be a problem? I also wondered about whether all themes would necessarily support highlighting of MW text--I tried it with a few of the default Sublime ones but without success again.

Can't help feeling I'm missing something really obvious here, so I'd be grateful for any ideas, no matter how naive they make me look.

Thanks and best
themicksa
 
Posts: 3
Joined: Thu Aug 23, 2012 9:49 am

Re: Mediawiki bundle

Postby shanin on Mon Oct 08, 2012 3:32 am

The syntax file of the current version of the texmate bundle give the same error to me, I have installed a previous version and it work fine.
shanin
 
Posts: 1
Joined: Tue Oct 02, 2012 12:35 am

Re: Mediawiki bundle

Postby themicksa on Fri Oct 12, 2012 4:24 pm

Hey Shanin,
I finally got round to trying your suggestion. I replaced the code of Mediawiki.tmLanguage with this version
https://github.com/textmate/mediawiki.t ... tmLanguage
and Bingo! it did the trick. All working lovely now. Thanks a bundle!
themicksa
 
Posts: 3
Joined: Thu Aug 23, 2012 9:49 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 20 guests