Home Download Buy Blog Forum Support

Package Control Testing Needed!

Package Control Testing Needed!

Postby wbond on Mon Nov 19, 2012 3:10 pm

I'm about to release the first new version of Package Control since early March. Yikes – that took way too long!

Please spend some time today if you can using the testing version. I am hoping to push out the new version tomorrow, Nov 20th, 2012.

If you can, please test:

  • Upgrading to the new version of Package Control
  • Installing packages
  • Removing packages
  • Upgrading a single package
  • Upgrading all packages

The link above covers some of the big additions/fixes. Also there have been fixes for handling upgrading in-use DLL files on Windows, not disabling packages when running upgrade all, handling non-ascii characters in the file path to the SSL CA certs bundle file, plus a whole bunch of other small things.

If you do find any issues, please post them at https://github.com/wbond/sublime_package_control/issues. Thanks for the help everyone!
wbond
 
Posts: 528
Joined: Mon Feb 28, 2011 5:33 am

Re: Package Control Testing Needed!

Postby senzo on Tue Nov 20, 2012 8:50 am

I have tested your points with no issues.
senzo
 
Posts: 106
Joined: Tue May 24, 2011 9:17 am

Re: Package Control Testing Needed!

Postby wbond on Tue Nov 20, 2012 1:29 pm

So far the only bug I've heard about was with OS X 10.6, and I've released an update for that (v1.5.0.22). This afternoon I think I'll pull the trigger and release PC v1.6.
wbond
 
Posts: 528
Joined: Mon Feb 28, 2011 5:33 am

Re: Package Control Testing Needed!

Postby thowland on Tue Nov 20, 2012 6:35 pm

Works for me- seems to solve the pesky http proxy problems I had before.
thowland
 
Posts: 3
Joined: Wed Jan 11, 2012 6:51 pm

Re: Package Control Testing Needed!

Postby gekko on Wed Nov 21, 2012 8:22 am

thowland wrote:Works for me- seems to solve the pesky http proxy problems I had before.

+1
gekko
 
Posts: 9
Joined: Mon Aug 27, 2012 8:29 am

Re: Package Control Testing Needed!

Postby iamntz on Thu Nov 22, 2012 7:15 am

Also works for me. Packages are not disabled anymore, which actually was the main problem for me :mrgreen:

Thanks!
iamntz
 
Posts: 911
Joined: Fri Apr 29, 2011 8:52 am
Location: Romania

Re: Package Control Testing Needed!

Postby MikeC on Fri Nov 23, 2012 2:53 pm

Nope, still getting "Package Control: Error downloading channel. URL error [Errno 10061] No connection could be made because the target machine actively refused it downloading https://sublime.wbond.net/repositories.json. This is even with http_proxy, proxy_username and proxy_password all configured manually.

I've never seen Package Control work at all on this box, though, so this isn't evidence of a regression.
MikeC
 
Posts: 13
Joined: Wed Feb 22, 2012 9:17 pm

Re: Package Control Testing Needed!

Postby wbond on Fri Nov 23, 2012 3:45 pm

MikeC wrote:Nope, still getting "Package Control: Error downloading channel. URL error [Errno 10061] No connection could be made because the target machine actively refused it downloading https://sublime.wbond.net/repositories.json. This is even with http_proxy, proxy_username and proxy_password all configured manually.

I've never seen Package Control work at all on this box, though, so this isn't evidence of a regression.


It sounds like you have a firewall or virus scanner blocking connection attempts. Every similar report I've heard has been caused by a program in one of those two categories.
wbond
 
Posts: 528
Joined: Mon Feb 28, 2011 5:33 am

Re: Package Control Testing Needed!

Postby MikeC on Fri Nov 23, 2012 4:00 pm

wbond wrote:It sounds like you have a firewall or virus scanner blocking connection attempts. Every similar report I've heard has been caused by a program in one of those two categories.


Not entirely convinced. A browser running on the same box via the same proxy can retrieve https://sublime.wbond.net/repositories.json just fine.
MikeC
 
Posts: 13
Joined: Wed Feb 22, 2012 9:17 pm

Re: Package Control Testing Needed!

Postby qgates on Sat Nov 24, 2012 12:29 am

MikeC wrote:
wbond wrote:It sounds like you have a firewall or virus scanner blocking connection attempts. Every similar report I've heard has been caused by a program in one of those two categories.


Not entirely convinced. A browser running on the same box via the same proxy can retrieve https://sublime.wbond.net/repositories.json just fine.

Perhaps double-check that Mike. Modern firewalls are clever; they can inspect on more than just the source/target IP or DNS. For example, your browser will connect with a browser user agent (UA) string, whereas Package Control probably uses a custom UA string. A tight firewall may only let packets through with a known browser UA string, and could block anything that isn't a legitimate browser on port 80 for example.

If you can temporarily disable your firewall altogether for a moment and try that'll seal it :)

S
qgates
 
Posts: 212
Joined: Mon Nov 05, 2012 4:33 pm

Next

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 23 guests