Home Download Buy Blog Forum Support

OS X: Unable to type German Umlaute on US keyboard

OS X: Unable to type German Umlaute on US keyboard

Postby driple on Tue Nov 06, 2012 6:18 pm

Hi,

I’m using a Macbook laptop with an US keyboard (and US layout) to type German text. For German Umlaute this is done by first typing alt-u, and then the respective letter, like u, a, o, whose Umlaut you need, e.g.: alt-u, u gives ü; alt-u, a gives ä. (Sounds clumsy? Yeah, but I like the US layout for various reasons, and I’m used to it.)

However, this method is not working in ST2. Not at all. No input is produced. I think ST2 is the first app where I encounter such a behaviour.

Any idea where to look, what to do?

Thanks.

--Hans

####Edit: A restart of ST2 helped. A little benign bug? :)

####Edit 2: Not so benign a bug: Very soon, the inability to input Umlaute returns, within minutes; a restart helps in each case, but this is really unfortunate. Apparently, the functionality of alt-u just stops. Using build 2217.
driple
 
Posts: 3
Joined: Thu May 12, 2011 9:48 am

Re: OS X: Unable to type German Umlaute on US keyboard

Postby senzo on Wed Nov 14, 2012 10:36 am

I'm considering moving to the same setup (buying a MacBook with a US layout). Did you find a solution for this?

I didn't test it but this seems to be interesting for this setup: http://hci.rwth-aachen.de/USGermanKeyboard. Maybe it helps.
senzo
 
Posts: 106
Joined: Tue May 24, 2011 9:17 am

Re: OS X: Unable to type German Umlaute on US keyboard

Postby driple on Fri Nov 23, 2012 12:18 pm

senzo,

unfortunately, I haven’t found a solution yet.

I get the ("unscientific") impression, that things improved slightly with the dev build 2220; something definitely got changed compared to build 2217 (the 2.0.1 release version), since in 2220 you see tiny dotted lines, something like a cursor contour, when pressing alt-u. However, while I was hoping this meant things got fixed, the situation remains essentially unchanged, as of yet. After a couple of minutes, every time, all the time, alt-u stops working.

Maybe (but again, this is an unscientific observation), the problem is triggered even faster when using full screen distraction free mode (which I think is very nice).

As of now, this alt-u problem is a show-stopper for me, going back to TextMate for the time being -- and missing sorely ST2’s distraction free mode and its overall nicer code display. (And speed.)

I’m going to try the USGermanKeyboard layout (thanks very much for the link!), this sounds interesting. Hopefully though, nothing else is changed besides the Umlaute input. In every other respect I very much prefer the US layout. (I post back when I have tried it out.)

Here’s hoping that ST2’s alt-u issue is fixed over time.

NB.: Maybe I should note that I am on a 10.6.8 32-bit system, i.e. on a rather dated one. I’m getting hit with problems on other occasions too, since developers are by now often unable to check their code on 32-bit systems. So maybe you should check the situation on a "modern" 64-bit Mac (all models since late 2006, i.e. since "forever"), maybe the issue doesn’t exist there.
driple
 
Posts: 3
Joined: Thu May 12, 2011 9:48 am

Re: OS X: Unable to type German Umlaute on US keyboard

Postby senzo on Fri Nov 23, 2012 12:59 pm

I switched my keyboard layout to US for 10 min and can still type Umlaute. Did you try to revert to a fresh state to be sure that it is a problem in sublime text and not in a plugin? (http://www.sublimetext.com/docs/2/revert.html)
senzo
 
Posts: 106
Joined: Tue May 24, 2011 9:17 am


Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 12 guests