Home Download Buy Blog Forum Support

Cannot use AltGr after installing PowerUser package

Cannot use AltGr after installing PowerUser package

Postby ekolguy on Mon Dec 21, 2009 1:25 pm

Hello everyone!

After installing PowerUser package I canot type some symbols (Characters like {} , [] and $) which are typed with the help of AltGr key, they just do not appear on screen. I am using Turkish Q layout (http://en.wikipedia.org/wiki/File:KB_Turkey.svg). Anyone could give me a hint on how to get rid of this annoyance?

Thanks a lot!
ekolguy
 
Posts: 41
Joined: Thu Dec 17, 2009 8:50 am

Re: Cannot use AltGr after installing PowerUser package

Postby EJ12N on Wed Dec 23, 2009 4:14 pm

ekolguy wrote:Hello everyone!

After installing PowerUser package I canot type some symbols (Characters like {} , [] and $) which are typed with the help of AltGr key, they just do not appear on screen. I am using Turkish Q layout (http://en.wikipedia.org/wiki/File:KB_Turkey.svg). Anyone could give me a hint on how to get rid of this annoyance?

Thanks a lot!


Umm no idea why it's happening but let's give it a shot...
EDIT: Ok the solution below works, I changed my keyboard layout to the one mentioned and mapped the right alt key to altgr, tried typing symbols after doing solution below and works :D

go to Default.sublime-keymap under PowerUser folder and find this code

Code: Select all
  <!-- Select Tabs by numbers -->
  <binding key="ctrl+alt+1" command="selectView 1" />
  <binding key="ctrl+alt+2" command="selectView 2" />
  <binding key="ctrl+alt+3" command="selectView 3" />
  <binding key="ctrl+alt+4" command="selectView 4" />
  <binding key="ctrl+alt+5" command="selectView 5" />
  <binding key="ctrl+alt+6" command="selectView 6" />
  <binding key="ctrl+alt+7" command="selectView 7" />
  <binding key="ctrl+alt+8" command="selectView 8" />
  <binding key="ctrl+alt+9" command="selectView 9" />
  <binding key="ctrl+alt+0" command="selectView 10" />


Comment it out and try to type start typing symbols away! :)
EJ12N
 
Posts: 281
Joined: Tue Apr 21, 2009 5:23 pm

Re: Cannot use AltGr after installing PowerUser package

Postby ekolguy on Thu Dec 24, 2009 10:18 am

Fantastic sollution Jon, thanks!

Metin
ekolguy
 
Posts: 41
Joined: Thu Dec 17, 2009 8:50 am

Re: Cannot use AltGr after installing PowerUser package

Postby EJ12N on Tue Jan 05, 2010 5:40 pm

ekolguy wrote:Fantastic sollution Jon, thanks!

Metin

/me no jon :P but no problema!
EJ12N
 
Posts: 281
Joined: Tue Apr 21, 2009 5:23 pm

Re: Cannot use AltGr after installing PowerUser package

Postby spirit on Sun Sep 26, 2010 7:01 pm

I'm having the exact same problem. I don't understand your solution as my bindings to move from one file to another are already bind with alt+ctrl not altgr...
any clue ?

Edit: sorry, I read too fast. When uncommenting those lines it works again. Still, those shortcuts were good :) how to get both ?
spirit
 
Posts: 5
Joined: Fri Jan 15, 2010 10:07 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 40 guests