Home Download Buy Blog Forum Support

Gem Browser (For Rails Devs and people who use Bundler)

Gem Browser (For Rails Devs and people who use Bundler)

Postby bbonamin on Mon Jan 07, 2013 10:32 pm

Gem Browser


For Ruby on Rails Developers and others using Bundler.

Image
Description
This plugin takes the hassle off when trying to read the code of gems you are using in a Rails (or ruby with bundler) project. Gem Browser provides a simple command called 'List Gems', which will list all the gems that have been installed via bundle for the project folder (via the bundle list command), and will open any gem that you choose in a new window with the code ready for inspection and EVEN modification in real time (via the bundle show command and a call to the sublime text 2 command line utility)

Gem Browser has been tested in OS X with RVM, Linux with rbenv and Windows with RubyInstaller.

You can install it via the Package Control and get the code from https://github.com/NaN1488/sublime-gem-browser

Contact us via twitter @bbonamin or @nan1488

Known bugs
Doesn't work with projects that use rvm gemsets (yet)

Updates
Version 0.1-alpha (initial version)
bbonamin
 
Posts: 1
Joined: Wed Dec 19, 2012 7:33 pm

Re: Gem Browser (For Rails Devs and people who use Bundler)

Postby jbrooksuk on Tue Jan 08, 2013 12:05 pm

I love you.
jbrooksuk
 
Posts: 778
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: Gem Browser (For Rails Devs and people who use Bundler)

Postby lushoe on Thu Mar 14, 2013 3:27 pm

Hi Question-

Installed railsinstaller (using windows) and sublime.


Then I was instructed to create hidden folder from the command prompt doing

C:\ subl /.gemrc

Sublime opens with that folder name

Then instructed to save the below text in order to get rid of the gem files that installed that we dont need....
Listing 1.2 from Michael Hartl: http://ruby.railstutorial.org/ruby-on-r ... c-rubygems

install: --no-rdoc --no-ri
update: --no-rdoc --no-ri

issue is it keeps saying it cant find the file (see attached)

someone suggested to use notepad ++ instead bc sublime supposedly has issues but I do not wish to change editors. Any advice?
Attachments
Sublime gemrc error.JPG
Sublime gemrc error.JPG (26.53 KiB) Viewed 1976 times
lushoe
 
Posts: 1
Joined: Thu Mar 14, 2013 3:19 pm

Re: Gem Browser (For Rails Devs and people who use Bundler)

Postby francescob on Thu Mar 14, 2013 4:42 pm

.gemrc should be a file not a folder
francescob
 
Posts: 20
Joined: Mon Apr 23, 2012 2:52 pm


Return to Plugin Announcements

Who is online

Users browsing this forum: Google [Bot] and 9 guests