Home Download Buy Blog Forum Support

RubyTest Output Not Showing Up

RubyTest Output Not Showing Up

Postby jgriffin on Thu Jan 17, 2013 1:59 am

I realize my question involves the RubyTest plug-in but I'm wondering if possibly it is setup related. I installed the RubyTest add-in and it seems to be working as keyboard shortcuts work and it spawns off a bundle exec command or bin/rspec command if I edit the settings file. However, I get no test output in the small window at bottom of screen whatsoever. If I go to the console and copy out the command and run in a dos window it works just fine.

Could this issue be privileges related in the installation at all?

I am using the Git Bash window to work in. I have determined upon closer inspection that my rspec command I have in my settings file is as follows:
"run_single_rspec_command": "bin/rspec {relative_path} -l{line_number}"

It gets translated into:
bin/rspec spec\features\static_pages_spec.rb -l9

I had changed bundle exec to bin/rspec. So it contains a / character. However {relative_path} is being translated using backslashes as if I'm running in a DOS window. Given I'm running in a Git Bash window can I have {relative_path} popped out in Unix format not Windows format.

I'm not sure if the "bin/rspec spec\features\static_pages_spec.rb -l9" line is what's causing no output to appear?

Regards,
Jeff
jgriffin
 
Posts: 1
Joined: Thu Jan 17, 2013 1:56 am

Re: RubyTest Output Not Showing Up

Postby TicketsNFines on Mon Mar 31, 2014 3:21 pm

I encountered the exact same problem today. It says "Building" next to the ST console (where the line xx, column yy stuff is) , but no output is printed after it's done. Works fine when executed through cmd. Anyone with an idea why might this happen?
TicketsNFines
 
Posts: 1
Joined: Mon Mar 31, 2014 3:17 pm


Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 24 guests