Home Download Buy Blog Forum Support

Text selection and scrolling with mouse Debian

Text selection and scrolling with mouse Debian

Postby bobland on Thu Aug 30, 2012 4:46 am

I've encountered a strange issue in 2217 regarding text selection with a mouse (Logitech Performance MX) on Linux (XMonad, Gnome 3 on Debian Sid, running on Virtualbox Windows 7 host).

When I click-drag with mouse on a single line, downwards, or upwards, the text window will scroll upwards, selecting text from the initial click to the current mouse position (or to the top of the text area depending on scrolling speed). The erratic scrolling makes text selection very difficult.

Similarly, when clicking on the minimap, and moving up or down with the mouse, the scroll bar will erratically jump to the top of scroll area then back to where the mouse is.

I've compared this on several VMs and it looks like it *may* be XOrg-related - 2217 does not exhibit the above on a vanilla Debian Squeeze install. At the same time, scrolling/text selection with mouse with Gnome 3's GEdit is not affected on Debian Sid...

Many thanks in advance!


Posts: 3
Joined: Thu Aug 30, 2012 3:18 am

Re: Text selection and scrolling with mouse Debian

Postby tossi on Mon Sep 24, 2012 1:29 pm

Same here?!?

Im working on openSUSE11.4 (KDE4)and start evaluating Sublime Text 2 (build 2217).
When I click in the text, the text cursor is moved where the mouse cursor is, as expected, also moving the mouse wheel works as expected.
However, when I click+drag the mouse, the whole window is moved instead of selecting text.

I also tried setting the locale like suggested in viewtopic.php?f=2&t=3597 but it does not help.
Running sublime_text --debug does not yield any output in my case.

What could I do to fix it or at least help debugging this further?



*** UPDATE ***

When I start sublime_text as root, selecting text with the mouse works as expected. Just I can not access my nfs shares...

So what is the difference when running it as root?

*** UPDATE ***

In my case this seems to be related to the GTK settings. These are not existing on my root account, but KDE seems to create a default configuration.

After I deleted (moved ...) my .gtkrc-2.0-kde4 the issue was gone. :D

We still need to find out what specifically interferes! It seems to be within GTK theme 'oxygen-gtk'.
Posts: 2
Joined: Mon Sep 24, 2012 1:19 pm

Re: Text selection and scrolling with mouse Debian

Postby donkass on Sun Oct 28, 2012 6:51 pm


I also have this issue and do not have any .gtkrc-* files at all.

I'm on ArchLinux using XMonad in a VirtualBox VM and have little or no GUI related stuff much beyond Sublime on my machine.
SLT2 build is 2217.

Very specifically what happens with me is:
  • If the file is scrolled to any point that the beginning of the file is not visible any modifications to my selection via mouse dragging will cause the window to scroll upwards until it reaches the top and can't scroll any further.
  • There is a flicker of the entire document being selected for just a split second before my visible selection returns to the 'real' one that I currently am modifying with the mouse.
  • I have no errors or messages in the console at any time while this is happening.

None of the other mentioned solutions do anything for me and I get the symptoms regardless of which user I run with (root vs. other) or any variables. I do not have Gnome, KDE or anything else to be setting anything up in the background for me either.
Posts: 1
Joined: Sun Oct 28, 2012 6:40 pm

Re: Text selection and scrolling with mouse Debian

Postby bobland on Wed Jan 30, 2013 10:27 am

Hi folks,

I recently did a dist-upgrade on Sid, and 2220 now works properly after several months of copying with erratic scrolling, so this was either a GTK/X problem after all.


Posts: 3
Joined: Thu Aug 30, 2012 3:18 am

Re: Text selection and scrolling with mouse Debian

Postby drewmate on Sat Jun 01, 2013 7:40 am

I'd just like to reiterate that running dist-upgrade seemed to clear up the strange scrolling/selection problem for me. I've been using Linux Mint in a VirtualBox and experienced strange erratic scrolling. It was cleared up by running

Code: Select all
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get dist-upgrade --fix-missing

The last command may not have been necessary, but it was complaining that some packages may not have been installed correctly, so I did that too just to be safe.

After the packages all updated, I restarted the virtual machine and re-opened Sublime Text. Scrolling and selecting text now works like a charm. No more weird jumping!
Posts: 1
Joined: Sat Jun 01, 2013 7:33 am

Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 34 guests