Home Download Buy Blog Forum Support

Any way to turn off auto completion in the comments ?

Any way to turn off auto completion in the comments ?

Postby Pwipwi on Fri Mar 09, 2012 10:13 am

I have tried changing "auto_complete_selector": "source - comment" to "auto_complete_selector": "source" to no avail.

I am slightly annoyed with the auto completer trying to write lengthy comments that sometimes, some words are auto completed.

This is of course a very minor annoyance, but I wanted to know if it was possible to to achieve what I described.
Pwipwi
 
Posts: 11
Joined: Tue Feb 07, 2012 10:31 am

Re: Any way to turn off auto completion in the comments ?

Postby qrlozte on Sun Feb 03, 2013 2:49 pm

Why am I having the opposite problem of yours?
I can't turn ON auto completion in the comments, the setting is:

// Controls what scopes auto complete will be triggered in
"auto_complete_selector": "source - comment",

Anyone knows how to turn it on? T_T
qrlozte
 
Posts: 4
Joined: Fri Jan 25, 2013 3:52 pm

Re: Any way to turn off auto completion in the comments ?

Postby FichteFoll on Sun Feb 03, 2013 3:15 pm

Considerung how selectors work
Code: Select all
"auto_complete_selector": "source",

should enable it for all source (not text or html) and
Code: Select all
"auto_complete_selector": "source - comment",

should enable it for all source (not text or html) but not within comments.
FichteFoll
 
Posts: 313
Joined: Fri Mar 16, 2012 11:49 pm
Location: Germany

Re: Any way to turn off auto completion in the comments ?

Postby qrlozte on Sun Feb 03, 2013 3:22 pm

FichteFoll wrote:Considerung how selectors work
Code: Select all
"auto_complete_selector": "source",

should enable it for all source (not text or html) and
Code: Select all
"auto_complete_selector": "source - comment",

should enable it for all source (not text or html) but not within comments.

Thanks :D
qrlozte
 
Posts: 4
Joined: Fri Jan 25, 2013 3:52 pm

Re: Any way to turn off auto completion in the comments ?

Postby Jibz on Sun Feb 03, 2013 11:12 pm

I've got

Code: Select all
"auto_complete_selector": "source - (comment, string.quoted)"

to disable auto-complete inside string literals as well.

Think I picked that up from here.
Jibz
 
Posts: 14
Joined: Fri Feb 01, 2013 10:56 am


Return to General Discussion

Who is online

Users browsing this forum: danpyq and 14 guests

cron