Home Download Buy Blog Forum Support

Go To Symbol in Project showing only open files

Go To Symbol in Project showing only open files

Postby atomi on Mon Feb 04, 2013 7:52 pm

Go To Symbol in Project is working fine in 3006
But 3007 and up it only lists symbols in currently open files.

Also if I close the Sublime Text 3 application window a Sublime Text process remains open with high disk usage.
Tested on Winx64 only.
atomi
 
Posts: 342
Joined: Thu Jan 20, 2011 5:06 pm
Location: Los Angeles CA US

Re: Go To Symbol in Project showing only open files

Postby atomi on Wed Feb 06, 2013 5:12 am

So also I zipped the ColdFusion package to a sublime-package file and put it in Data/Installed Packages instead of the the Data/Packages folder and the Go To Symbol in Project works.

Edit: here is the error I seen in console sometimes "indexing: failed to join process 6004"
atomi
 
Posts: 342
Joined: Thu Jan 20, 2011 5:06 pm
Location: Los Angeles CA US

Re: Go To Symbol in Project showing only open files

Postby atomi on Wed Feb 06, 2013 6:34 am

Also if I put my package into the Data/Installed Packages as a zipped sublime-package my plugin.py won't load.

I put scattered print statement all over and console doesn't show any of them.
atomi
 
Posts: 342
Joined: Thu Jan 20, 2011 5:06 pm
Location: Los Angeles CA US

Re: Go To Symbol in Project showing only open files

Postby Narretz on Fri Feb 08, 2013 10:05 am

This happens for me in a different configuration:
When I open a project created with Sublime Text 2, it will not index (or show) symbols in the whole project.
Just now, I did "New Workspace for project" and it indexed everything, and it is also available in the old workspace.
Narretz
 
Posts: 41
Joined: Mon Feb 04, 2013 5:33 pm


Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 15 guests