Home Download Buy Blog Forum Support

Problems with cut shortcut... may be bug

Re: Problems with cut shortcut... may be bug

Postby peter222 on Sat Dec 29, 2012 5:27 pm

last days ctrl+X doesn't work me too

I tried:
Code: Select all
sublime.log_commands(True)

ctrl+x do nothing (no action)

only double ctrl+x do cut action (after second time)... what happens? No other ctrl-x shortcut conflict in my settings
Linux Mint 13
peter222
 
Posts: 21
Joined: Tue Jan 03, 2012 11:14 pm

Re: Problems with cut shortcut... may be bug

Postby agibsonsw on Sat Dec 29, 2012 6:41 pm

it is generally a plug-in that causes these kinds of faults. Try disabling plug-ins and check the Console (Control ' ) for error messages.
"I'm here to save your life. But if I'm going to do that, I'll need total uninanonynymity." Me Myself & Irene.
agibsonsw
 
Posts: 901
Joined: Fri Jan 27, 2012 9:11 pm

Re: Problems with cut shortcut... may be bug

Postby peter222 on Sat Dec 29, 2012 8:54 pm

No plugins was installed last days in SublimeText, now I use shift + del (another cut shortcut in ST2) but it is not so comfortable now.
It is another strange behaviour of ST2, another one I described there viewtopic.php?f=3&t=8621
No answer. Shame that ST2 support don't respond for user requests :(
Linux Mint 13
peter222
 
Posts: 21
Joined: Tue Jan 03, 2012 11:14 pm

Re: Problems with cut shortcut... may be bug

Postby peter222 on Wed Jan 02, 2013 12:23 pm

I found another workaround.... after pressing ctrl+X notging happens, but next, when press up arrow, selected text disappers and goes to clipboard.
Just magic :))
Linux Mint 13
peter222
 
Posts: 21
Joined: Tue Jan 03, 2012 11:14 pm

Re: Problems with cut shortcut... may be bug

Postby stestagg on Wed Jan 09, 2013 6:10 pm

I think I've found a workaround here:

viewtopic.php?f=3&t=8767&p=41750#p41750
stestagg
 
Posts: 3
Joined: Wed Jan 09, 2013 6:07 pm

Re: Problems with cut shortcut... may be bug

Postby benwoody on Thu Jan 17, 2013 4:17 pm

Having the same issue here. Ubuntu 11.04 with XFCE

Cut does actually copy the selected item to my clipboard, but it doesn't remove it from the line.

Also, using the arrow keys doesn't move the visible cursor, which is extremely frustrating.
benwoody
 
Posts: 1
Joined: Thu Jan 17, 2013 4:14 pm

Re: Problems with cut shortcut... may be bug

Postby michaelxor on Wed Feb 06, 2013 5:36 pm

I am having the same issue.

Any "cut" action (via ctrl+x, shift+delete, Edit > Cut) results is loss of responsiveness for the cursor for roughly 5 seconds. In fact, if I use the arrow keys to move to a different line during this time (indicated by the margin highlight rather than frozen cursor), the cut action applies to whichever line I end up on rather than the line / lines where the cut action originated. There is no error output in the console (actually the console reports the cut action immediately as shown in a video in one of the earlier comments), and I think it's relatively safe to say it's not caused by conflicting packages because I am using a fresh install.

As many others have said, this makes the editor essentially unusable, and I would love to hear of a fix. Can anyone verify whether or not this issue is fixed in Sublime Text 3 beta?

Running Ubuntu 11.04 32-bit w/ XFCE.

For now, I've gotten things to work sub-optimally using the workaround mentioned by stestagg (combination of installing parcellite & killing xfce4-settings-helper).
michaelxor
 
Posts: 1
Joined: Wed Feb 06, 2013 5:12 pm

Re: Problems with cut shortcut... may be bug

Postby scott-tw on Wed Feb 13, 2013 5:15 pm

Same issue as everyone else here, however I am on Ubuntu 12.10 with the default Unity 3D (not XFCE). Tried resetting per the recomendation and like everyone else it did not solve the issue.

My use case:

1. ctl+x/Edit > Cut
2. Text is copied but not cut.
3. Cursor position freezes for approx, 5 seconds, however the arrow keys can reposition the cursor state so that when the cursor starts responding again, it is respositioned.
scott-tw
 
Posts: 2
Joined: Wed Feb 13, 2013 5:06 pm

Re: Problems with cut shortcut... may be bug

Postby scott-tw on Mon Feb 18, 2013 9:45 pm

Well after applying the updates via the Ubuntu Update Manager and restarting this morning, I am no longer experiencing the Ctrl+x/cut cursor issue.

For anyone that is interested, here is the dpkg.log from my update this morning: https://gist.github.com/scottweaver/4980844#file-ubuntu-12-10-dpkg-log
scott-tw
 
Posts: 2
Joined: Wed Feb 13, 2013 5:06 pm

Re: Problems with cut shortcut... may be bug

Postby bianc0niglio on Fri Apr 19, 2013 9:30 am

I think I have nailed it.
For the XFCE users: just close your Clipman applet and retry. It should work flawlessly.

I think it's some sort of run condition on the clipboard management between the applet and the editor.
bianc0niglio
 
Posts: 2
Joined: Fri Apr 19, 2013 9:25 am

PreviousNext

Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 23 guests