Home Download Buy Blog Forum Support

broken plugins due different versions of the same module

broken plugins due different versions of the same module

Postby wst on Tue Feb 05, 2013 9:07 pm

Plugins usually include third-party modules and tested with specific versions of theirs.
Plugins can use different versions of the same third-party module and plugins can be broken due module with incorrect version.
Forced replacement the current module by the module with the correct version by one plugin can break other plugins that expect a another version.

For example SublimeLinter/SublimeAutoPEP8 conflict: https://github.com/SublimeLinter/SublimeLinter/issues/296#issuecomment-13148056
wst
 
Posts: 2
Joined: Tue Feb 05, 2013 3:24 pm

Re: broken plugins due different versions of the same module

Postby wst on Thu Feb 07, 2013 10:15 am

I've starting to use "import pluginname.module" instead of "import module" or "from lib import module" to avoid this.
wst
 
Posts: 2
Joined: Tue Feb 05, 2013 3:24 pm


Return to Plugin Development

Who is online

Users browsing this forum: Google [Bot], roycyt and 7 guests