Home Download Buy Blog Forum Support

Vintage Auto return to command mode

Vintage Auto return to command mode

Postby Allen on Mon Feb 25, 2013 4:50 pm

I'm sure this is possible, but I'm not sure where to start to make it happen... I'm looking for a macro that will automatically switch me back to command mode when I leave the tab (IE switching tabs, switching programs, etc.).
Allen
 
Posts: 43
Joined: Sun Jan 24, 2010 2:50 pm

Re: Vintage Auto return to command mode

Postby guillermooo on Mon Feb 25, 2013 5:04 pm

I you are using S3, you can give Vintageous a try. It does that and much more Vintage doesn't:

https://github.com/guillermooo/Vintageous
guillermooo
 
Posts: 728
Joined: Thu Jul 23, 2009 9:06 am

Re: Vintage Auto return to command mode

Postby Allen on Mon Feb 25, 2013 5:22 pm

guillermooo wrote:I you are using S3, you can give Vintageous a try. It does that and much more Vintage doesn't:

https://github.com/guillermooo/Vintageous


Great, installing now--thanks guillermooo!
Allen
 
Posts: 43
Joined: Sun Jan 24, 2010 2:50 pm

Re: Vintage Auto return to command mode

Postby Allen on Mon Mar 04, 2013 8:57 pm

When using Vintageous, if I switch tabs and it auto-returns to command mode sublime indicates that the content of the file has changed and that it needs to be saved (tab text turns red). Is this a shortcoming of the plugin or ST3, is it fixable?

Edit:
I noticed that hitting Esc also caused the tab to indicate changes to be saved. I was able to reproduce this consistently, then disabled Vintageous and switched back to Vintage mode to test to see if the issue also happened there. It didn't. I then switched back to Vintageous and now it doesn't seem to be happening at all. Weird.
Allen
 
Posts: 43
Joined: Sun Jan 24, 2010 2:50 pm

Re: Vintage Auto return to command mode

Postby guillermooo on Mon Mar 04, 2013 9:31 pm

It's a known issue.

https://github.com/guillermooo/Vintageous/issues/126

I'll have to check what does Vintage do differently.
guillermooo
 
Posts: 728
Joined: Thu Jul 23, 2009 9:06 am

Re: Vintage Auto return to command mode

Postby Allen on Mon Mar 04, 2013 9:44 pm

Cool, thanks.
Allen
 
Posts: 43
Joined: Sun Jan 24, 2010 2:50 pm


Return to General Discussion

Who is online

Users browsing this forum: Exabot [Bot] and 12 guests