Home Download Buy Blog Forum Support

Package Setup Error: Can't Run Sublime

Package Setup Error: Can't Run Sublime

Postby jayzawrotny on Sat Sep 22, 2012 10:22 pm

Unable to run package setup:

Traceback (most recent call last):
File "./PackageSetup.py", line 165, in upgrade
upgradePackage(pkg, pristinedir, datadir, backupdir)
File "./PackageSetup.py", line 158, in upgradePackage
os.path.join(backupdir, base), inhibitOverwrite)
File "./PackageSetup.py", line 90, in upgradeArchive
writeFile(fname, newar.read(f))
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 834, in read
return self.open(name, "r", pwd).read()
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 857, in open
zinfo = self.getinfo(name)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 824, in getinfo
'There is no item named %r in the archive' % name)
KeyError: "There is no item named u'nathos-sass-textmate-bundle-e7395ab/Snippets/{\\u2026}.tmSnippet' in the archive"
---------------------------------------------------

I've deleted the package in package control settings, deleted the plugin files in packages, and added the sass pages to my settings' ignored packages list. But every time I run sublime it shows that error and creates the packages/sass directory again.
jayzawrotny
 
Posts: 3
Joined: Tue Mar 27, 2012 6:58 pm

Re: Package Setup Error: Can't Run Sublime

Postby thomax on Tue Feb 12, 2013 8:33 am

I have the same problem. I'm pretty sure what caused it: I pasted in a couple of really strange unicode symbols and saved the text file. ST2 crashed, and when I try to reopen it again, it get the following.

Unable to run package setup:
Traceback (most recent call last):
File "./PackageSetup.py", line 165, in upgrade
upgradePackage(pkg, pristinedir, datadir, backupdir)
File "./PackageSetup.py", line 158, in upgradePackage
os.path.join(backupdir, base), inhibitOverwrite)
File "./PackageSetup.py", line 90, in upgradeArchive
writeFile(fname, newar.read(f))
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 834, in read
return self.open(name, "r", pwd).read()
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 857, in open
zinfo = self.getinfo(name)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 824, in getinfo
'There is no item named %r in the archive' % name)
KeyError: "There is no item named u'sass-textmate-bundle-sublime/Snippets/{\\u2026}.tmSnippet' in the archive"

There is an ok-button at the bottom of this dialog, which quites ST2.

Any help to get my favorite editor up and running again would be much appreciated!
thomax
 
Posts: 2
Joined: Tue Feb 12, 2013 8:29 am

Re: Package Setup Error: Can't Run Sublime

Postby thomax on Tue Feb 12, 2013 9:13 am

This solved my problem:
Code: Select all
rm Library/Application\ Support/Sublime\ Text\ 2/Installed\ Packages/Sass.sublime-package
thomax
 
Posts: 2
Joined: Tue Feb 12, 2013 8:29 am

Re: Package Setup Error: Can't Run Sublime

Postby jkdreaming on Mon Feb 25, 2013 6:55 pm

How would I fix this in windows? I'm having the same issue and the paths I'm seeing seem like mac paths. To be fare sublime works great on my mac with no errors. Also what file do I paste this in? I've actually deleted the whole app and re-installed with zero effect too.
jkdreaming
 
Posts: 3
Joined: Mon Feb 25, 2013 6:50 pm

Re: Package Setup Error: Can't Run Sublime

Postby jkdreaming on Mon Feb 25, 2013 7:10 pm

Here is a pic of the error.
Attachments
sublime error.JPG
Here is the error pic
sublime error.JPG (35 KiB) Viewed 801 times
jkdreaming
 
Posts: 3
Joined: Mon Feb 25, 2013 6:50 pm


Return to Technical Support

Who is online

Users browsing this forum: xyresic and 20 guests