Home Download Buy Blog Forum Support

How to exit multiple cursors with vintage mode enabled

How to exit multiple cursors with vintage mode enabled

Postby stdavis on Tue May 14, 2013 2:09 pm

So I'm trying out vintage mode and am loving it except one thing. When I try to exit multiple cursor mode by pressing "esc", it just switches to command mode without exiting multiple cursor mode. Is there any other key binding to exit multiple cursor mode that doesn't collide with vim command mode? I realize that I could click with the mouse, but that the whole reason why I'm learning vim; so that I don't have to touch my mouse.

Thanks!
stdavis
 
Posts: 7
Joined: Tue May 01, 2012 1:09 pm

Re: How to exit multiple cursors with vintage mode enabled

Postby larister on Mon Jun 10, 2013 3:27 pm

You could add a keymapping for it in your Preferences -> Key Bindings (User) like so-

{ "keys": ["escape"], "command": "single_selection", "context":
[
{ "key": "num_selections", "operator": "not_equal", "operand": 1 },
{ "key": "setting.command_mode", "operand": true }
]
}

However, I was in your position a couple of months back, but now I would advise against overriding the default behaviour on this one. Just press escape twice if you really need to cancel the multiple selection.

Command mode is kind of the 'default' that you will find yourself in most of the time (great explanation of why here: http://vimeo.com/53144573), so you'll often want to break out of multiple selection in to command mode. If you can, stick it out and hopefully you won't regret it.
larister
 
Posts: 1
Joined: Mon Jun 10, 2013 3:18 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Yahoo [Bot] and 21 guests