Home Download Buy Blog Forum Support

Make Sublime Text forget loaded files

Make Sublime Text forget loaded files

Postby Nolan on Sun Jun 16, 2013 5:34 pm

Hi, sometime Sublime Text takes a long time to load because of the files I regularly edit plus the syntax highlighting, which eat up some resources. But most of the time I just want ST to load so I can start typing a to-do list right away. Even though, I'll need to wait for the long files to load.
What is the setting I can append to settings - user to make Sublime Text forget the files I was working in the last session?
Using Sublime Text 2.0.1 on Windows 7.
Thanks!
Nolan
 
Posts: 18
Joined: Fri May 17, 2013 5:20 am

Re: Make Sublime Text forget loaded files

Postby adzenith on Mon Jun 17, 2013 6:33 pm

For any setting you can go Preferences>Default to search for the possible settings. Try looking there.
adzenith
 
Posts: 1214
Joined: Mon Oct 19, 2009 9:12 pm

Re: Make Sublime Text forget loaded files

Postby Nolan on Tue Jun 18, 2013 12:08 am

Sorry, I was a noob until I saw your answer. Sublime Text is so fantastic we don't have to delve into menus and submenus to find the specific thing. A simple Ctrl+F did the job. it saved me time! Thanks a lot, sorry for the dumb question.
I found this:
Code: Select all
"remember_open_files": true,

So I'll put that on settings-user :)

Edit: my happiness lasted short. I got this error...
Image
...when I edited "true" to "false" on above settings file. Mine is as follows:
Code: Select all
{
   "auto_complete_commit_on_tab": true,
   "color_scheme": "Packages/Color Scheme - Default/Cobalt.tmTheme",
   "default_encoding": "UTF-8 with BOM",
   "dictionary": "Packages/Languages/Portuguese (Brazilian).dic",
   "fallback_encoding": "Unicode",
   "font_face": "Consolas",
   "font_size": 14.0,
   "remember_open_files": false,
   "ignored_packages":
   [
      "Vintage"
   ],
   "theme": "Soda Light.sublime-theme"

I can't load Sublime Text until I edit back the file by outside. Why can't I change that from true to false?
Nolan
 
Posts: 18
Joined: Fri May 17, 2013 5:20 am

Re: Make Sublime Text forget loaded files

Postby adzenith on Wed Jun 19, 2013 6:14 pm

It looks like you might be missing a } at the end of the file.
adzenith
 
Posts: 1214
Joined: Mon Oct 19, 2009 9:12 pm

Re: Make Sublime Text forget loaded files

Postby Nolan on Mon Jul 22, 2013 12:41 pm

Thanks adzenith. Sorry for taking so long to come back.
Nolan
 
Posts: 18
Joined: Fri May 17, 2013 5:20 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 11 guests