Home Download Buy Blog Forum Support

Can't make default editor in windows

Can't make default editor in windows

Postby sublimetextuser on Mon Jul 15, 2013 1:08 am

I have been using sublime text 2 to edit some websites I have. The other day, it wouldn't open files and gave me a message that it was old and that I should download a new version. I had been getting messages to update for a little while, but I always ignored them.

So I downloaded the new version and installed it. But now I can't use "open with" on my window machine to open files. I can't set it as the default text editor. And, additionally, my ftp program won't let me use it to edit files on a remote server. That's the big part. Is there a way to fix this?
sublimetextuser
 
Posts: 2
Joined: Mon Jul 15, 2013 12:54 am

Re: Can't make default editor in windows

Postby sublimetextuser on Mon Jul 15, 2013 8:15 am

Well problem solved. I re installed the program and there was an option to add it to the menu when you right click on a file. "Open With.." still won't work but that's ok because there is now another option to open with sublime text that is separate.

And my FTP program had a separate sorta hidden configuration option to manually select the editor program to edit files on the remote server. So even though sublime text still no longer shows up under the default list programs to edit files with alongside notepad and wordpad etc, I can still open files in sublime text by setting the ftp program to use it every time. Which is handy for times like today when I wanted to make a bunch of css and markup changes on the server without having do download/re-upload etc or use a different editor.

So while it was nice, and a little nostalgic to get re-acquainted with notepad++ again today, I'm back to using sublime text. Yay!
sublimetextuser
 
Posts: 2
Joined: Mon Jul 15, 2013 12:54 am

Re: Can't make default editor in windows

Postby kane_t on Tue Jul 16, 2013 3:28 pm

I think I can help you get Open With/default editor working. The problem is that the Sublime Text uninstaller doesn't remove a particular registry entry referring to Sublime Text 2's sublime_text.exe, which prevents Windows from adding an entry for Sublime Text 3's sublime_text.exe.

To correct it manually, open regedit and navigate to Computer\HKEY_CLASSES_ROOT\Applications\, find the sublime_text.exe entry, and delete it. You should now be able to set Sublime Text 3 as the default editor for anything you want.
kane_t
 
Posts: 1
Joined: Tue Jul 16, 2013 3:23 pm

Re: Can't make default editor in windows

Postby fer33646 on Wed Jul 17, 2013 5:35 pm

kane_t wrote:To correct it manually, open regedit and navigate to Computer\HKEY_CLASSES_ROOT\Applications\, find the sublime_text.exe entry, and delete it. You should now be able to set Sublime Text 3 as the default editor for anything you want.


110% true, thank you!
fer33646
 
Posts: 1
Joined: Wed Jul 17, 2013 5:33 pm

Re: Can't make default editor in windows

Postby Shoebox on Tue Aug 06, 2013 7:09 pm

[quote="kane_t"
To correct it manually, open regedit and navigate to Computer\HKEY_CLASSES_ROOT\Applications\, find the sublime_text.exe entry, and delete it. You should now be able to set Sublime Text 3 as the default editor for anything you want.[/quote]

Signed up for the forum to explicitly thank you for posting this. I've been going crazy for a couple days with this. Thanks!
Shoebox
 
Posts: 1
Joined: Tue Aug 06, 2013 7:07 pm

Re: Can't make default editor in windows

Postby aspect_mkn8rd on Sun Aug 18, 2013 7:13 am

kane_t wrote:I think I can help you get Open With/default editor working. The problem is that the Sublime Text uninstaller doesn't remove a particular registry entry referring to Sublime Text 2's sublime_text.exe, which prevents Windows from adding an entry for Sublime Text 3's sublime_text.exe.

To correct it manually, open regedit and navigate to Computer\HKEY_CLASSES_ROOT\Applications\, find the sublime_text.exe entry, and delete it. You should now be able to set Sublime Text 3 as the default editor for anything you want.

thx, it works perfectly.
aspect_mkn8rd
 
Posts: 2
Joined: Sun Aug 18, 2013 7:11 am

Re: Can't make default editor in windows

Postby thowland on Wed Sep 11, 2013 1:21 pm

Awesome, worked for me- thanks!
thowland
 
Posts: 3
Joined: Wed Jan 11, 2012 6:51 pm

Re: Can't make default editor in windows

Postby Z0MB1EL4ND on Mon Sep 30, 2013 5:47 pm

Shoebox wrote:
kane_t wrote:To correct it manually, open regedit and navigate to Computer\HKEY_CLASSES_ROOT\Applications\, find the sublime_text.exe entry, and delete it. You should now be able to set Sublime Text 3 as the default editor for anything you want.


Signed up for the forum to explicitly thank you for posting this. I've been going crazy for a couple days with this. Thanks!


Same here, much appreciated! Thank you!
Z0MB1EL4ND
 
Posts: 1
Joined: Mon Sep 30, 2013 5:46 pm

Re: Can't make default editor in windows

Postby bradleyflood on Tue Dec 10, 2013 5:39 am

Thank you! Can't believe this isn't part of Sublime's Uninstaller -- what's with that?
bradleyflood
 
Posts: 3
Joined: Tue Dec 10, 2013 5:38 am

Re: Can't make default editor in windows

Postby BUGMENOT! on Tue Dec 10, 2013 2:11 pm

yes, that worked for me too, thx


Villa Palmar Timeshare Truth
Last edited by BUGMENOT! on Wed Mar 12, 2014 5:43 pm, edited 1 time in total.
BUGMENOT!
 
Posts: 20
Joined: Thu Sep 19, 2013 1:54 pm

Next

Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 26 guests