Home Download Buy Blog Forum Support

[CLOSED] Toggle comment - Stop working after update

[CLOSED] Toggle comment - Stop working after update

Postby bob.rosset on Wed Jul 17, 2013 12:16 am

Hello guys, I recently updated my Sublime Text 2 version to the latest build (v2.0.2 build 2221) and something that I was able to do in the past, is not available anymore, "Toggle comments".

I don't think the "toggle comment" shortcut is not working, 'cause "toggle comment" on the menu is unavailable as well. I searched on Google for:
- sublime text 2 comment block not working
- sublime text 2 toggle comment not working linux
- sublime text 2 toggle comment stop working linux
And some other combinations of keywords, with no luck at all.

So right now, I cannot comment a block of code automatically, I have to do it manually (old style... line by line), and it's a pain in the a*ss.
I already checked the shortcuts of course, and compared those with my OSX version (there the toggle comment works), it's pretty much the same.

Suggestions/possible solutions will be more than appreciated.

I'm running Sublime Text 2 on Fedora 18 (Linux) and my previous build, with the same configuration, worked like a charm.
Last edited by bob.rosset on Thu Jul 25, 2013 8:12 pm, edited 1 time in total.
bob.rosset
 
Posts: 6
Joined: Wed Jul 17, 2013 12:02 am
Location: Buenos Aires, Argentina

Re: Toggle comment - Stop working after update

Postby rob49152 on Wed Jul 17, 2013 8:06 am

kind of the same thing has happened to me. if I am within any " " I can't type the / of </
I upgraded two plugins today and it looks like it's the Tag.sublime.package in my case. Once I disable that it works again.
rob49152
 
Posts: 14
Joined: Sat Jun 15, 2013 10:02 pm

Re: Toggle comment - Stop working after update

Postby bob.rosset on Wed Jul 17, 2013 7:23 pm

Thanks mate. I'll check this Tomorrow.

Any clue of why we get this kinda errors?

Cheers
bob.rosset
 
Posts: 6
Joined: Wed Jul 17, 2013 12:02 am
Location: Buenos Aires, Argentina

Re: Toggle comment - Stop working after update

Postby bob.rosset on Fri Jul 19, 2013 9:03 pm

Hey Rob... quick question, how can I disable a plugin? I tried to find it on the folders but the folder is empty, I might be looking at the wrong place.

Thanks in advance mate.
bob.rosset
 
Posts: 6
Joined: Wed Jul 17, 2013 12:02 am
Location: Buenos Aires, Argentina

Re: Toggle comment - Stop working after update

Postby rmdiaconu on Fri Jul 19, 2013 9:42 pm

Cmd-Shift-P on Mac or Ctrl-Shift-P on Windows -> Write "Remove Package" -> Enter -> Select the package to be removed
rmdiaconu
 
Posts: 3
Joined: Wed Jul 17, 2013 8:15 pm
Location: Romania

Re: Toggle comment - Stop working after update

Postby bob.rosset on Mon Jul 22, 2013 6:57 pm

No luck yet. I get to the packages folder. But there's no Tag package. :(
bob.rosset
 
Posts: 6
Joined: Wed Jul 17, 2013 12:02 am
Location: Buenos Aires, Argentina

Re: Toggle comment - Stop working after update

Postby bob.rosset on Mon Jul 22, 2013 7:02 pm

Just for the record, I deleted the .config/sublime-text-2 folder and created a new one, and the problem is still there.
bob.rosset
 
Posts: 6
Joined: Wed Jul 17, 2013 12:02 am
Location: Buenos Aires, Argentina

Re: Toggle comment - Stop working after update

Postby bob.rosset on Mon Jul 22, 2013 7:18 pm

How to solve it:
- Download the app again.
- Delete the old app.
- Delete the .config/sublime-text-2 folder.
- Prepare a cubata (Rhum and coke).
- Unarchive the app.
- Move it to the appropriate folder.

Don't know what changed between versions, but something fu*ked up my version.
bob.rosset
 
Posts: 6
Joined: Wed Jul 17, 2013 12:02 am
Location: Buenos Aires, Argentina

Re: [CLOSED] Toggle comment - Stop working after update

Postby gbonanome on Wed Sep 25, 2013 9:39 am

On Ubuntu with Sublime Text 3, for me worked only the solution found on this thread: viewtopic.php?f=3&t=11157&p=53927#p53927

Replacing ctrl+/ and ctrl+shift+/ with ctrl+7 and ctrl+shift+7 in keybindings worked for me on ST3 on Ubuntu.
gbonanome
 
Posts: 3
Joined: Wed Sep 25, 2013 9:06 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], qgates, Yahoo [Bot] and 28 guests