Home Download Buy Blog Forum Support

[ST3 b3047] Vintage mode ; , does nothing

[ST3 b3047] Vintage mode ; , does nothing

Postby pneubauer on Tue Jul 09, 2013 12:03 pm

Hi,

I'm running the Sublime Text 3 Beta Build 3047 on Linux with Vintage Mode enabled.
The ";" and "," motion keys are supposed to navigate to the next occurence of the character given in the last "f" motion.

In the following example file:
Code: Select all
This is an interesting example line.


Starting with the cursor at the beginning of the line, 'f i' will correctly navigate to the 'i' in 'This'. Successive 'f i' commands will move to the different 'i's in the line. However, ';' and ',' do not move the cursor at all.
This problem never occured for me in Sublime Text 2.
pneubauer
 
Posts: 1
Joined: Tue Jul 09, 2013 11:48 am

Re: [ST3 b3047] Vintage mode ; , does nothing

Postby adri on Sat Aug 03, 2013 10:22 pm

+1 I really miss this functionality because it's already muscle memory. Is there a real bug/issue tracker?
adri
 
Posts: 1
Joined: Sat Aug 03, 2013 10:20 pm

Re: [ST3 b3047] Vintage mode ; , does nothing

Postby skuroda on Sat Aug 03, 2013 11:57 pm

Well, there is an unofficial bug tracker (don't know how much attention it gets though from the ST team)

https://github.com/SublimeText/Issues/issues?state=open

In addition, you may want to take a look at Vintageous. As guillermoo puts it on the README,

guillermooo wrote:Vintageous is a rewrite of Vintage with the aim to make it more similar to Vim.


Anyways, development is active on it, so you may want to try it.
skuroda
 
Posts: 687
Joined: Fri Oct 05, 2012 8:11 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 22 guests