Home Download Buy Blog Forum Support

Problem with ST3 and Webdav folder added to project

Problem with ST3 and Webdav folder added to project

Postby apmoh on Wed Aug 14, 2013 8:55 pm

Running ST3 on Windows 7 Professional SP1

I have a 'drive' provided by WebDrive (see WebDrive) that accesses a webdav connection.

When I add a folder from this drive to a virgin ST3 project, I get furious CPU usage, memory starts disappearing, and drive activity becomes continuous. WebDrive provides a monitor, which shows that the entire webdav folder is being cached. This is a big folder, with LOTS of files...

This did not happen with ST2, in fact I still have ST2 installed and following the exact same steps above results in 'normal' operation. That is, I can access the contents of the webdav folder through the project, but there is no attempt to cache the entire folder.

Memory, once consumed does not seem to come back until a reboot. I noticed this problem when I returned from lunch to find 8GB of RAM consumed. Closing ST3 does NOT release the memory.

On the one hand, the problem seems to be a memory leak when the files are cached - probably not your problem (though I could conceive of situations where it could be). On the other hand, ST2 didn't cause this ruckus, so this is new behaviour and therefore suspect.
apmoh
 
Posts: 1
Joined: Wed Aug 14, 2013 8:26 pm

Re: Problem with ST3 and Webdav folder added to project

Postby KimSRT on Mon Aug 19, 2013 9:11 pm

Hello,

Please visit our online helpdesk at http://www.srthelpdesk.com (I work for the publisher of WebDrive). Someone will be happy to help with the memory consumption issue.
KimSRT
 
Posts: 1
Joined: Mon Aug 19, 2013 9:09 pm


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 14 guests