Home Download Buy Blog Forum Support

PuTTY Fatal Error shows while Package Control Installation

PuTTY Fatal Error shows while Package Control Installation

Postby Marslo on Tue Sep 10, 2013 9:19 am

Hi,

There is a error about "PuTTY Fatal Error" always shows while I trying to install package by Package Control (ctrl + alt + p -> Input "Package Contorl install" -> Enter).

Well, I cannot upload the screenshot right now. Let me describe it:
Code: Select all
PuTTY Fatal Error:
Disconnected: No supported authentication methods available(server send: publickey).


The information about the environment:
- Sublime Text:
Code: Select all
Copyright @ 2006-2013 Sublime HQ Pty Ltd
Stable Channel, Build 3047

- System (win7)
Code: Select all
>> systeminfo
OS Name:                   Microsoft Windows 7 Enterprise
OS Version:                6.1.7601 Service Pack 1 Build 7601
System Manufacturer:       Dell Inc.
System Model:              OptiPlex 790
System Type:               x64-based PC
Marslo
 
Posts: 3
Joined: Tue Sep 10, 2013 8:37 am

Re: PuTTY Fatal Error shows while Package Control Installation

Postby wbond on Tue Sep 10, 2013 2:21 pm

Try setting ignore_vcs_packages to false: https://sublime.wbond.net/docs/settings ... s_packages. Alternatively you can remove any packages that you cloned using git and use Package Control's native HTTP support to install the package.

Most likely Package Control is trying to update a Git repo that is using plink.exe in some way. Other than that, I have no idea how Package Control could possibly have anything to do with PuTTY.
wbond
 
Posts: 519
Joined: Mon Feb 28, 2011 5:33 am

Re: PuTTY Fatal Error shows while Package Control Installation

Postby Marslo on Thu Sep 12, 2013 1:10 pm

Pity, It's still shown...
The Packages I've installed are:
Code: Select all
- CMD (Here is the details information: http://stackoverflow.com/questions/18606682/how-can-i-open-command-line-prompt-from-sublime-in-windows7)
- ConvertToUTF8
- CTags
- GBK Encoding Support
- GotoLastEdit
- Navigation History
- OpenSearchResult
- Package Control
- Theme - Soda
- Vintageous


My settings:
Code: Select all
{
   // Indent
   "auto_indent": true,
   "draw_indent_guides": true,
   "smart_indent": true   ,

   // Minimap
    "draw_minimap_border": true,
    "always_show_minimap_viewport": true,

    // Tab settings
   "soda_classic_tabs": true,
   "tab_size": 4,
   "translate_tabs_to_spaces": true,
   "use_tab_stops": true,
   "draw_white_space": "selection",

   // Style
   "find_selected_text": true,
   "font_face": "Monaco",
   "font_size": 12.0,
   "gutter": true,
   "highlight_line": true,
   "highlight_search_results": true,
   "word_wrap": false,
   "auto_match_enabled": true,
   "bold_folder_labels": true,
   "line_padding_bottom": 3,
   "Line_padding_top": 3,

   // Tabs
   "highlight_modified_tabs": true,
   "show_full_path": true,

   // code style
   "caret_style": "phase",
   "default_encoding": "GBK",
   "dictionary": "Packages/Language - English/en_US.dic",

   // Match
   "match_brackets": true,
   "match_brackets_angle": true,
   "match_brackets_braces": true,
   "match_brackets_content": true,
   "match_brackets_square": true,

   // Theme
   "color_scheme": "Packages/User/Monokai Soda.tmTheme",
   "theme": "Soda Dark 3.sublime-theme",
   // "theme": "Soda Dark.sublime-theme",
   "trim_trailing_white_space_on_save": true,

   // Vim style
   "vintage_ctrl_keys": false,
   "vintage_start_in_command_mode": true,

   "auto_upgrade_last_run": 1331660912,
   "ignore_vcs_packages": false,

   "file_exclude_patterns":
   [
      ".tags",
      ".tags_sorted_by_file",
      ".gemtags",
      ".git"
   ],

   "ignored_packages":
   [
      "ShellScript",
      "Clojure",
      "Matlab",
      "Go",
      "ActionScript",
      "RestructuredText",
      "Markdown",
      "Graphviz",
      "Haskell",
      "Lisp",
      "Scala",
      "LaTeX",
      "Objective-C",
      "ASP",
      "D",
      "OCaml",
      "TCL",
      "Erlang",
      "R",
      "C#",
      "Makefile"
   ],


My shortcuts:
Code: Select all
[
    { "keys": [",", "x"], "command": "toggle_comment", "args": { "block": false } },

    { "keys": ["alt+shift+j"], "command": "navigation_history_back"},
    { "keys": ["alt+shift+l"], "command": "navigation_history_forward"},

    { "keys": ["alt+k"], "command": "scroll_lines", "args": {"amount": 1.0 } },
    { "keys": ["alt+j"], "command": "scroll_lines", "args": {"amount": -1.0 } },

    { "keys": ["ctrl+]"], "command": "navigate_to_definition"},
    // { "keys": ["ctrl+t"], "command": "jump_back"},

    // move
    { "keys": ["alt+l"], "command": "next_view" },
    { "keys": ["alt+h"], "command": "prev_view" },
    { "keys": ["alt+b"], "command": "move", "args": {"by": "words", "forward": false} },
    { "keys": ["alt+f"], "command": "move", "args": {"by": "word_ends", "forward": true} },

    // ctrl + a: Begin of line; ctrl + e: end of line
    { "keys": ["ctrl+e"], "command": "set_motion", "args": {"motion": "vi_dollar"}, "context": [{"key": "vi_mode_normal_or_visual"}] },
    { "keys": ["ctrl+a"], "command": "set_motion", "args": {"motion": "vi_underscore"}, "context": [{"key": "vi_mode_normal_or_visual"}] },
    { "keys": ["ctrl+w"], "command": "delete_word", "args": { "forward": false, "sub_words": true }, "context": [{"key": "setting.command_mode", "operand": false}] },

    { "keys": ["alt+o"], "command": "open_dir", "args": {"dir": "$file_path", "file": "$file_name"} },
    { "keys": ["c", "m", "d"], "command": "cmd"}
]
Marslo
 
Posts: 3
Joined: Tue Sep 10, 2013 8:37 am

Re: PuTTY Fatal Error shows while Package Control Installation

Postby wbond on Thu Sep 12, 2013 1:41 pm

You put the ignore_vcs_packages setting in the wrong file. Check out https://sublime.wbond.net/docs/settings for the right place to put it.
wbond
 
Posts: 519
Joined: Mon Feb 28, 2011 5:33 am

Re: PuTTY Fatal Error shows while Package Control Installation

Postby Marslo on Thu Sep 12, 2013 1:47 pm

Okay, I've fixed this bug....
Just remove two folders Sublime Text 3 under the path of %APPDATA% and %LOCALAPPDATA%.
And reinstall Package Control and other packages.

Because I don't know how to remove Package Control independent.
Marslo
 
Posts: 3
Joined: Tue Sep 10, 2013 8:37 am

Re: PuTTY Fatal Error shows while Package Control Installation

Postby rasp on Mon Feb 10, 2014 8:38 pm

I have the same issue. I'm guessing that this has to do with Package Control setting the GIT_SSH environment variable if it finds TortoisePlink.exe on the system (see here). I'm guessing this causes git to launch TortoisePlink instead of OpenSSH.

If so, I think this behaviour should probably be changed or made configurable: TortoisPlink.exe comes with TortoiseGit, and does not imply with any certainty that it is actually being used. Am I missing some configuration possibility?
rasp
 
Posts: 4
Joined: Sat Mar 31, 2012 11:02 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 24 guests