Home Download Buy Blog Forum Support

[SOLVED] ST3 slow on Win8 64bit

Re: ST3 slow on Win8 64bit

Postby Arjan on Mon Oct 21, 2013 7:57 am

jps wrote:
Arjan wrote:
wbond wrote:Have you tried setting "index_files" to false?


Yes, that obviously "fixes" the problems, but I need to have it on.


It's not at all obvious to me. Just to be sure, can you confirm that you did indeed try this and that the symptoms disappeared after turning it off?


Yes, index_files=false completely solves the problem.

I have found that removing the most insanely large files makes the slowdown much less likely (there's a couple of generated >1gb text files with bulk sql commands)
Arjan
 
Posts: 88
Joined: Thu Jan 24, 2013 1:08 pm

Re: ST3 slow on Win8 64bit

Postby kentor on Mon Oct 21, 2013 9:42 pm

Arjan wrote:Yes, index_files=false completely solves the problem.

I have found that removing the most insanely large files makes the slowdown much less likely (there's a couple of generated >1gb text files with bulk sql commands)

u don't say?
kentor
 
Posts: 2
Joined: Mon Oct 21, 2013 9:41 pm

Re: ST3 slow on Win8 64bit

Postby jps on Tue Oct 22, 2013 12:16 am

Arjan wrote:I have found that removing the most insanely large files makes the slowdown much less likely (there's a couple of generated >1gb text files with bulk sql commands)

Files over 4 MB aren't indexed btw.

In case you missed them, could you also provide the information requested in the above few posts?
jps
Site Admin
 
Posts: 3071
Joined: Wed Mar 19, 2008 12:33 pm

Re: ST3 slow on Win8 64bit

Postby Arjan on Tue Oct 22, 2013 11:56 am

jps wrote:
Arjan wrote:I have found that removing the most insanely large files makes the slowdown much less likely (there's a couple of generated >1gb text files with bulk sql commands)

Files over 4 MB aren't indexed btw.

In case you missed them, could you also provide the information requested in the above few posts?


I answered them already.

If >4MB files aren't indexed, I am really puzzled about what is going on.
Arjan
 
Posts: 88
Joined: Thu Jan 24, 2013 1:08 pm

Re: ST3 slow on Win8 64bit

Postby qgates on Tue Oct 22, 2013 12:17 pm

Arjan wrote:...
I answered them already.
...


jps is referring to posts on the previous page:

jps wrote:Can you expand on what you mean by unresponsive? Also, is it a gradual thing, or does it happen all at once?


jps wrote:What did ProcExplorer show you?


If he's trying to figure out what is going on for you, you'll need to provide as much info as you can since clearly he's unable to reproduce your problem.
qgates
 
Posts: 224
Joined: Mon Nov 05, 2012 4:33 pm

Re: ST3 slow on Win8 64bit

Postby Arjan on Tue Oct 22, 2013 11:56 pm

qgates wrote:
Arjan wrote:...
I answered them already.
...


jps is referring to posts on the previous page:

jps wrote:Can you expand on what you mean by unresponsive? Also, is it a gradual thing, or does it happen all at once?


jps wrote:What did ProcExplorer show you?


If he's trying to figure out what is going on for you, you'll need to provide as much info as you can since clearly he's unable to reproduce your problem.


1. Not gradual, happens when project is opened.

2. ProcExplorer show 4 Sublime processes, each using ~28MB ram, and I just noticed that the processes oscillates between 0% and 100%.
Arjan
 
Posts: 88
Joined: Thu Jan 24, 2013 1:08 pm

[SOLVED] Re: ST3 slow on Win8 64bit

Postby Arjan on Wed Oct 23, 2013 9:55 am

FINALLY, PROBLEM "SOLVED!"

It was an interaction with McAfee (!) Turn off mcafee, no slowdown in st3.

Since mcafee plays well with st2, I assume there's something tripping up st3 indexing when mcafee is running.

Amusingly, mcafee's process is idling when I open the project, while st3 processes are going haywire for some reason. I suppose there might be some mcafee service processes churning along, but I'm to tired of this to even look further...

Admittedly, I had issue with mcafee and a diffing tool before, so I'm inclined to just uninstall the crap and declare st3 healthy.

Sorry about the noise.
Arjan
 
Posts: 88
Joined: Thu Jan 24, 2013 1:08 pm

Re: [SOLVED] ST3 slow on Win8 64bit

Postby jbrooksuk on Wed Oct 23, 2013 11:29 am

I'm glad to see you got your problem solved, however you should really apologise to Jon for flaming him.
jbrooksuk
 
Posts: 778
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: [SOLVED] ST3 slow on Win8 64bit

Postby Arjan on Wed Oct 23, 2013 11:33 am

jbrooksuk wrote:I'm glad to see you got your problem solved, however you should really apologise to Jon for flaming him.


I think he should apologize for not replying to paying customers until they are pushed to flaming.
Arjan
 
Posts: 88
Joined: Thu Jan 24, 2013 1:08 pm

Re: [SOLVED] ST3 slow on Win8 64bit

Postby guillermooo on Wed Oct 23, 2013 1:35 pm

Arjan, feeling pushed to flaming sounds like a very subjective predicament.

As far as I can tell, all your posts have implied since the very beginning that ST was at fault, and in a pretty uncompromising tone too.

Even when you got the developer's attention you were not as cooperative as you could have been at first.

You have every right to demand better service, but a more constructive attitude would perhaps have made things easier.
guillermooo
 
Posts: 729
Joined: Thu Jul 23, 2009 9:06 am

PreviousNext

Return to General Discussion

Who is online

Users browsing this forum: jbrooksuk, Soulsbane and 31 guests