Home Download Buy Blog Forum Support

Menu unresponsive and laggy in ST3 build 3054, Ubuntu 13.10

Menu unresponsive and laggy in ST3 build 3054, Ubuntu 13.10

Postby edubkendo on Mon Nov 11, 2013 8:32 pm

So, I recently had to upgrade to Ubuntu 13.10. Until that point, Sublime had integrated quite well with Unity, and the global menu had worked fine. (To explain, in Ubuntu Unity (Ubuntu's default window manager/ desktop) application menus open up in a bar at the very top of the screen, so that whichever window has focus, that window's menu will be the one displayed. Further, unless you move your mouse up there it hides, creating a very clean look. Further, it integrates with some functionality called the HUD, which is much like subl's command pallete. Pressing 'alt' brings up a search bar which lets you quickly find and execute commands from the menu.)

As I said, before 13.10, this was working fine. Now, however, the menu is often either completely unresponsive, or extremely laggy. Accessing menu items via the HUD seems to 'mostly' work, but using the mouse is totally broken. If the HUD worked 100% correctly, I'd just use that, although, for actions which will require a mouse anyways, like opening a folder, I typically just go ahead and switch to the mouse anyways, since beginning the action via the keyboard and then switching to the mouse buys you nothing.

Further, attempting to use the menu often results in locking up the entire application. This has been incredibly frustrating.

When I open a file with sublime via `gksudo subl /blah/blah/blah` , as it always has, subl opens under the root's context, and when it does that, the menu appears attached to the application instead of in the global menu. In that case, it functions perfectly. If I could figure out how to open sublime so that it opens under my normal user context, but opens without the global menu, I'd be satisfied, as much as I do enjoy the global menu and HUD when it works correctly, this would be an ok workaround. I've tried uninstalling sublime and untarring the tarball in my home directory, and opening it via the command line like, "~/installs/sublime_text_3/sublime_text" thinking this might work like when I open with "gksudo" but it does not.

I've noticed a few other applications whose menu used to integrate with the global menu, but now does not, so I am thinking there were probably changes in 13.10 to the way it works or the API. Or maybe its just an ubuntu bug.

Any help with this would be appreciative.
edubkendo
 
Posts: 30
Joined: Fri May 18, 2012 2:43 pm
Location: Nashville

Re: Menu unresponsive and laggy in ST3 build 3054, Ubuntu 13.10

Postby edubkendo on Wed Nov 20, 2013 2:49 am

Seems resolved with latest dev build.
edubkendo
 
Posts: 30
Joined: Fri May 18, 2012 2:43 pm
Location: Nashville


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 23 guests