Home Download Buy Blog Forum Support

Sublime lagging?

Sublime lagging?

Postby swamyveera on Mon Jun 24, 2013 3:16 am

Hi there,

After the recent update, there seems to be a nagging lag while typing.

At the point of creating this topic, i am running version 3 build 3041.

These are the issues i am facing

1. Delay when typing: I did'nt have this problem before i updated to the current build. There is a little lag as i type, i have to wait for the characters to appear.
2. Cursor location: sublime does'nt seem to save the cursor location. A typical scenario is:
[list=]Am editing a html/php file
I leave sublime text to refresh the browser
When i come back and click on sublime, the cursor moves to the area where i clicked rather than holding its position. I believe this was not the case previously.
I have a multi-monitor setup so, clicking is the easiest option for me. This definitely adds a little frustration since i keep doing this a lot.
[/list]



3. Sounds while typing: Not really sure if it this is an issue. There is a audio feed back (like a bubble sound) as i type in sublime. This really makes me go nuts :) . I am not sure where to turn off these sounds? Any suggestions?


Thanks
swamyveera
 
Posts: 4
Joined: Mon Jun 24, 2013 3:02 am

Re: Sublime lagging?

Postby svenax on Mon Jun 24, 2013 10:14 pm

It definitely sounds like you have installed some other software that is causing these issues in Sublime Text. Maybe a keyboard logger or some macro utility?
svenax
 
Posts: 150
Joined: Tue Dec 20, 2011 12:47 pm

Re: Sublime lagging?

Postby swamyveera on Tue Jun 25, 2013 2:47 am

Hi there
I believe that is not the case.
I dont' have the "lag" in other applications, only sublimtext. And it started only after updating to the latest build.
swamyveera
 
Posts: 4
Joined: Mon Jun 24, 2013 3:02 am

Re: Sublime lagging?

Postby swamyveera on Tue Jun 25, 2013 4:34 am

Hi again
I just updated to the more recent build 3044 and the lag got even worse. I literally need to stop typing and wait for the characters to appear on screen

I really need help on this one, it is starting to get unusable. Any suggestions?


FYI, my system specs: Intel i7, Windows 7 64-Bit,RAM - 10 GB
Definitely enough hard disk space and processing power.

I don't think it is because of any hardware limitations.
swamyveera
 
Posts: 4
Joined: Mon Jun 24, 2013 3:02 am

Re: Sublime lagging?

Postby subhaze on Tue Jun 25, 2013 4:45 am

It could be caused by a third party plugin, I've had simliar issues like you've described when a plugin was eating up the CPU. You could try reseting your install to a fresh state http://www.sublimetext.com/blog/article ... text-2-faq
subhaze
 
Posts: 221
Joined: Tue Apr 09, 2013 3:22 am

Re: Sublime lagging?

Postby swamyveera on Tue Jun 25, 2013 5:00 am

For now, i reverted to sublime 2. I am hoping this can be fixed in future versions :(
swamyveera
 
Posts: 4
Joined: Mon Jun 24, 2013 3:02 am

Re: Sublime lagging?

Postby aortmann on Sat Nov 30, 2013 6:25 pm

I got the same problem it was in my fall the gitGutter plugin.
aortmann
 
Posts: 3
Joined: Fri Nov 29, 2013 10:20 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], mcmillion and 26 guests