Home Download Buy Blog Forum Support

Find/replace "wrap" not working right?

Find/replace "wrap" not working right?

Postby handycam on Sat Jan 21, 2012 5:59 pm

Unless I misunderstand...

I create a find/replace using a GREP which I want to perform on my document from the cursor position to end of document.

No other find options are on.

Replace all, and ALL the matches change, even those above the cursor. Shouldn't that only happen if I chose "wrap"?
Mac OS 10.9.3
ST 3 (3059)
handycam
 
Posts: 271
Joined: Tue Jan 03, 2012 2:42 pm

Re: Find/replace "wrap" not working right?

Postby EvilDragon on Thu Oct 10, 2013 2:21 pm

I can confirm this - Replace All definitely does not obey Wrap setting - it replaces all instances throughout the whole document.

This is with the latest ST3 beta build.


Please fix, it's annoying :)
EvilDragon
 
Posts: 12
Joined: Thu Oct 10, 2013 2:20 pm

Re: Find/replace "wrap" not working right?

Postby EvilDragon on Wed Nov 20, 2013 1:42 pm

Nobody can reproduce? I sure can...
EvilDragon
 
Posts: 12
Joined: Thu Oct 10, 2013 2:20 pm

Re: Find/replace "wrap" not working right?

Postby qgates on Thu Nov 21, 2013 12:36 am

I think this is by design; the wrap toggle is for find only. I agree that it should be better. SnR could get a number of improvements in Sublime; my other editor is far more flexible in this regard. I'm also not a fan of the behaviour when doing replace across lots of files - ie. Sublime opens them all in tabs, and they all need saving.
qgates
 
Posts: 205
Joined: Mon Nov 05, 2012 4:33 pm

Re: Find/replace "wrap" not working right?

Postby EvilDragon on Thu Apr 03, 2014 11:39 am

Is this ever going to be fixed? It's annoying as hell (and makes absolutely no sense whatsoever!) that wrap is not respected when replacing text!
EvilDragon
 
Posts: 12
Joined: Thu Oct 10, 2013 2:20 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 17 guests