Home Download Buy Blog Forum Support

Sublime Text 2 bug with

Sublime Text 2 bug with

Postby kib2 on Fri Jan 28, 2011 9:53 pm

I think I've found a bug (Windows 7, 32 bits), but I need confirmation.

1. Create a new Javascript file and save it (this is important);
2. Write somechars (whatever,ie "abcd"), select them, then press quote '.

The expected output should be:
Code: Select all
'abcd'

it is now:
Code: Select all
'


If you don't save the file on step 1, the bug is not here.
kib2
 
Posts: 38
Joined: Sun Mar 23, 2008 8:30 am
Location: France

Re: Sublime Text 2 bug with

Postby kib2 on Fri Jan 28, 2011 10:09 pm

Hi sublimator,

Double quotes works fine for me too, only single ones seems to have a problem.
kib2
 
Posts: 38
Joined: Sun Mar 23, 2008 8:30 am
Location: France

Re: Sublime Text 2 bug with

Postby kib2 on Fri Jan 28, 2011 10:18 pm

We can do without atm; Jon will certainly fix this very soon.
kib2
 
Posts: 38
Joined: Sun Mar 23, 2008 8:30 am
Location: France

Re: Sublime Text 2 bug with

Postby jps on Sun Jan 30, 2011 12:58 pm

This is caused by the "Object-Method-String.sublime-snippet" snippet. Its tabTrigger starts with a single quote, which causes a clash with the normal single quote key binding.
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Sublime Text 2 bug with

Postby kib2 on Sun Jan 30, 2011 1:40 pm

Indeed, thanks jps.
kib2
 
Posts: 38
Joined: Sun Mar 23, 2008 8:30 am
Location: France


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Yahoo [Bot] and 28 guests