Home Download Buy Blog Forum Support

BUG: default_line_ending does not work

BUG: default_line_ending does not work

Postby que on Tue Feb 22, 2011 5:27 pm

Sublime 2 always save new files using windows style (CRLF), even if i set "default_line_ending" to "unix".
But it works fine after i change it via menu (View -> Line Ending -> Unix).
-
PS: i'm on Windows (build 2029)
que
 
Posts: 18
Joined: Sat Jan 30, 2010 9:24 pm

Re: BUG: default_line_ending does not work

Postby jps on Wed Feb 23, 2011 8:55 am

It works for me, test steps are: (on Windows)

1. Add "default_line_ending": "unix" to User/Base file.sublime-settings. Save.
2. Press Ctrl+N, and check the View/Line Endings menu. Unix is checked.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: BUG: default_line_ending does not work

Postby que on Wed Feb 23, 2011 4:12 pm

Oh.. sorry.. it re-sets to windows (or system) when i open zero-length file (e.g created using touch)
que
 
Posts: 18
Joined: Sat Jan 30, 2010 9:24 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 20 guests