Home Download Buy Blog Forum Support

[BUG] find_selected_text doesn't work (resolved)

[BUG] find_selected_text doesn't work (resolved)

Postby mconigliaro on Tue Mar 08, 2011 4:49 pm

Is anyone else having trouble with the find_selected_text option in the alpha builds? The default seems to be set to true, and I'm definitely not overriding it in my user settings, but it has not worked for me on OSX since the option was introduced (I'm currently on build 2042).
Last edited by mconigliaro on Wed Mar 09, 2011 5:09 pm, edited 1 time in total.
mconigliaro
 
Posts: 4
Joined: Thu Mar 03, 2011 9:13 pm

Re: [BUG] find_selected_text doesn't work

Postby mconigliaro on Tue Mar 08, 2011 9:12 pm

OK, it looks like it works in the "find in files" dialog (ctrl + shift + f), but it does not work in the regular find dialog (ctrl + f)
mconigliaro
 
Posts: 4
Joined: Thu Mar 03, 2011 9:13 pm

Re: [BUG] find_selected_text doesn't work

Postby jps on Tue Mar 08, 2011 9:22 pm

You need to change the value in your user settings, rather than the default ones, as the one in Base File.sublime-settings is overridden by the Base File (OSX).sublime-settings. The Find in Files panel is currently ignoring this setting, which I'll fix.
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: [BUG] find_selected_text doesn't work

Postby mconigliaro on Wed Mar 09, 2011 5:07 pm

I see, so even though the default for "find_selected_text" is true in Base File.sublime-settings, it's set to false for some reason in Base File (OSX).sublime-settings. It was not obvious to me that this setting might only be disabled by default on OSX. But yeah, overriding this in my user file settings worked. Thanks!
mconigliaro
 
Posts: 4
Joined: Thu Mar 03, 2011 9:13 pm


Return to Technical Support

Who is online

Users browsing this forum: Alexa [Bot], Clams, Google [Bot] and 15 guests