Home Download Buy Blog Forum Support

build 3059 close file behaviour...

build 3059 close file behaviour...

Postby tmrefugee on Thu Dec 19, 2013 4:19 am

Is there a setting that gets back the old close file behaviour?

Prior to build 3059: when closing the last file, the window would then close (hooray). After build 3059: closing the last file, nothing happens. Feels like it might be related to this item in the 3059 changelog:

When the last file is closed, a new transient file is created automatically


I can't think of any other OS X app that has this kind of behaviour and it feels terrible. Hitting Cmd+W should close files then the window (like any other app in the OS X world).

If you tend to have multiple windows/projects open then you can't quickly close the ST window anymore. Either you need to use the mouse or another shortcut key.
tmrefugee
 
Posts: 2
Joined: Thu Dec 19, 2013 4:07 am

Re: build 3059 close file behaviour...

Postby sassembla on Thu Dec 19, 2013 7:00 am

In build 3059, close-behaviour never work to close the "Application's About window" too.

Can't close this window with "super + w" .
https://dl.dropboxusercontent.com/u/365 ... _01_01.png
sassembla
 
Posts: 12
Joined: Sat Apr 20, 2013 9:10 am

Re: build 3059 close file behaviour...

Postby cleaner416 on Thu Dec 19, 2013 9:45 pm

+1. Frustrating.
cleaner416
 
Posts: 1
Joined: Thu Dec 19, 2013 9:44 pm

Re: build 3059 close file behaviour...

Postby ekampp on Thu Dec 19, 2013 10:41 pm

I have the same regression experience.

The comment preceding the "close_windows_when_empty" setting states that "This is always enabled on OS X,changing it here won't modify the behavior." But: using OSX still doesn't allow me to close the window.

Effectively, the problem is that using the "command+w" shortcut has an extremely unexpected and counterintuitive results.
ekampp
 
Posts: 1
Joined: Thu Dec 19, 2013 10:38 pm

Re: build 3059 close file behaviour...

Postby jps on Fri Dec 20, 2013 3:21 am

By default, cmd+w will close the current window when the last file is closed. This behavior hasn't changed in 3059. If this isn't happening for you, you may want to consider http://www.sublimetext.com/docs/3/revert.html
jps
Site Admin
 
Posts: 3158
Joined: Wed Mar 19, 2008 12:33 pm

Re: build 3059 close file behaviour...

Postby tmrefugee on Fri Dec 20, 2013 6:12 am

Thanks for the suggestions. I actually went through the revert step already (and deleted ST2, ST3, reinstalled, basically got rid of everything involving ST that I could find!!)

My repro steps are as follows (just after reverting):

1. Start Sublime Text 3. Blank window opens (incidentally this window can be cmd-w closed)
2. File -> Open. Here I point it at a *directory*, for this example I used /Users. You should get a new window with the file browser down the left.
3. Press Cmd+W. Nothing happens on 3059. Earlier betas would close the window.

Thanks.
tmrefugee
 
Posts: 2
Joined: Thu Dec 19, 2013 4:07 am

Re: build 3059 close file behaviour...

Postby RBloeth on Fri Dec 20, 2013 8:52 am

Actually I'm confused. I don't want Sublime to close automatically when I close the last open tab, but when there is no open tab left, I want to be able to close sublime text with CTRL-W. This was possible in the previous build and all the versions before, but now I have to use the mouse to close the empty Sublime Text window.

Frustrating issue...
RBloeth
 
Posts: 14
Joined: Tue Dec 06, 2011 3:03 pm

Re: build 3059 close file behaviour...

Postby tvai on Fri Dec 20, 2013 3:56 pm

i use
Code: Select all
cmd+shift+w
now to close that last window
tvai
 
Posts: 1
Joined: Fri Dec 20, 2013 3:54 pm

Re: build 3059 close file behaviour...

Postby jps on Sat Dec 21, 2013 4:17 am

Thanks for the additional information, I can see the issue now. Will address for the next build.
jps
Site Admin
 
Posts: 3158
Joined: Wed Mar 19, 2008 12:33 pm

Re: build 3059 close file behaviour...

Postby joahg on Tue Feb 25, 2014 8:50 pm

ok, yeah, @tvai's fix works (using CMD+SHIFT+W to close the window), but it is surely an inconvenience introduced in the latest build... Hope to see this fixed soon :)
joahg
 
Posts: 1
Joined: Tue Feb 25, 2014 8:48 pm

Next

Return to Technical Support

Who is online

Users browsing this forum: marcoscibil, Yahoo [Bot] and 23 guests